New releases, updated docs, call for support

Hi all, this weekend [24 Jun 2023], some new things were released around Gramps Web:

Concerning the documentation, the user guide still lacks a lot of information. Personally, I am focused on all kind of development topics right now, so I don’t have time to improve the user docs. Any help there would be appreciated! It’s Github pages, so you don’t need to be a developer, some Markdown knowledge is sufficient.

Source: GitHub - gramps-project/web: Documentation for Gramps Web


The Gramps Web Sync add-on (Gramps Plugin) tool is also at a v1.0.2 release. It has now been migrated from the developer’s private repository to the Gramps-Project add-ons repository where the Plugin Manager can find and install it.

This Addon needs an advocate to adopt it and create a wiki page from the GitHub file.

You can download the ZIP and manually install or use the Isotammi addon ZIPinstall that you can add after pointing the Plugin Manager toward the Isotammi addon server.

This tool needs several users stress testing it:

  • a local server user
  • a self-hosted web server user who did a manual install
  • a self-hosted web server user who installed with Docker
  • a DigitalOcean Gramps Web droplet subscriber

This is a Mass Merging process, so be certain to follow stringent backup procedures.

1 Like

I tried several times to test it with apache (mod_wsgi) on ubuntu 22.04.02 without succes.
I always have the following error:
[Sun Jun 25 18:15:58.865443 2023] [wsgi:error] [pid 801003] [client] mod_wsgi (pid=801003): Exception occurred processing WSGI script ‘/home/public/webapi/’.
[Sun Jun 25 18:15:58.865841 2023] [wsgi:error] [pid 801003] [client] Traceback (most recent call last):
[Sun Jun 25 18:15:58.865895 2023] [wsgi:error] [pid 801003] [client] File “/home/public/webapi/”, line 27, in
[Sun Jun 25 18:15:58.865916 2023] [wsgi:error] [pid 801003] [client] from flask import Flask, abort, g, send_from_directory
[Sun Jun 25 18:15:58.865925 2023] [wsgi:error] [pid 801003] [client] File “/usr/local/lib/python3.10/dist-packages/flask/”, line 1, in
[Sun Jun 25 18:15:58.865933 2023] [wsgi:error] [pid 801003] [client] from . import json as json
[Sun Jun 25 18:15:58.865941 2023] [wsgi:error] [pid 801003] [client] File “/usr/local/lib/python3.10/dist-packages/flask/json/”, line 6, in
[Sun Jun 25 18:15:58.865948 2023] [wsgi:error] [pid 801003] [client] from …globals import current_app
[Sun Jun 25 18:15:58.865956 2023] [wsgi:error] [pid 801003] [client] File “/usr/local/lib/python3.10/dist-packages/flask/”, line 45, in
[Sun Jun 25 18:15:58.865963 2023] [wsgi:error] [pid 801003] [client] app_ctx: AppContext = LocalProxy( # type: ignore[assignment]
[Sun Jun 25 18:15:58.865978 2023] [wsgi:error] [pid 801003] [client] TypeError: LocalProxy.init() got an unexpected keyword argument ‘unbound_message’

Instead of using the default packages of ubuntu version, I used pip3 to install flask 2.1.3 as shown on several sites to fix this problem but without success.

That’s not quite correct, in fact the PR was merged two days ago: Add Gramps Web Sync addon by DavidMStraub · Pull Request #547 · gramps-project/addons-source · GitHub

However, since it took almost one year to merge, I need to check whether the merged code was still up to date with the other repo…

@SNoiraud what do you want to achieve? Using mod_wsgi is nowhere in the official docs. If you just want to run Gramps Web API, you can try (it’s just a flask app after all), but every issue that arises before you manage to run it is very likely unrelated to Gramps Web API, but to your Apache or Flask setup.

I only want to use the gramps_webapi on my apache server.
As there is no documentation, at each time I have a new error, i use the web to find a solution.
For me, your solution is too complicated. I don’t want to use docker.
Did you try to install your product on an apache server ?

It should normaly works with all python module from the ubuntu distribution.

My apache works correctly with mod_wsgi except with gramps_webapi.

What is the Flask setup ? where do you set it ?

1 Like

No. I am not interested in running Web API with mod_wsgi, I have never tried, and I don’t want to invest time into it as I don’t have a use case.

If you absolutely want to use Apache, why not reverse proxy to Gunicorn? There is no need to use Docker, but you can look at the Dockerfile to see how it is run.

But I suggest opening a separate topic for this.

I was unable to find it in the Gramps-Project GitHub repository. But COULD find it in yours.

I can navigate to the PR but not to a folder in the GitHub addon source. Neither in the Master nor Gramps51 branches. And it isn’t listed in the builtin plugins tools either.

Maybe I am looking for the wrong folder name Help me find the fully qualified path so it can be linked in the posting.

This is very odd. The link opens GitHub app and redirects to several levels above. I cannot get to that folder.

But if I paste the URL into a Firefox addressbar, it DOES work.

Make sure you checkout the “maintenance/gramps51” branch rather than the “gramps51” branch. I’m not sure why we have both.

It was the Mobile Discourse screwing with me … again.

Mobile Discourse was opening the link in the GitHub mobile app. Which was redirecting to a parent folder. (And I must have not been browsing down to that ‘maintenance’ branch.)

After flushing the mobile Discourse from my phone and using a regular browser, the links worked. This caused my phone to stop automatically trying to open the GitHub mobile app.