I'm not able to use Gramps Web Sync plugin (Web API Sync)

I’m using Gramps AIO64-5.1.5-1 on Windows 10
I manually installed the plugin as per instructions: GitHub - DavidMStraub/gramps-addon-webapisync: Development version of a Gramps addon to synchronize a local family tree with a Gramps Web API instance
Then when I click on the plugin from the menu it says plugin not loaded with error message: “(no error message)” and nothing else.

1 Like

just figure out how to check Gramps console:
this is the error
WARNING: _manager.py: line 308: Plugin error (from ‘webapisync’): No module named ‘typing’

Issue already reported to the developer, if you want to use it you will need to manually setup a development version of Gramps on windows or more easily Linux instead of using the Gramps AIO64-5.1.5-1 on Windows 10

which points to 0012073: [Windows AIO Installation] Add the module Lib/typing.py to the Windows AIO version which seems to indicate that it will be fixed when Gramps 5.2.x is released next year!

PS: somebody else also asked today about this addon and the reply was:

Closing as this addon has not been released to the general public and is in development please report the issue directly to the developer at:

Issues · DavidMStraub/gramps-addon-webapisync · GitHub

1 Like

many thanks, sorry I didn’t find that

We’re always working on improving Gramps documentation. But it is still more difficult than we would like to find the appropriate troubleshooting information when it is needed.

To help us improve, could you tell us where you searched before asking? (We won’t scold if you asked without searching. We need to know that too.)

I’m new to all these platform so surely I didn’t search correctly.
I searched here on discourse,
on GitHub - DavidMStraub/gramps-addon-webapisync: Development version of a Gramps addon to synchronize a local family tree with a Gramps Web API instance
on Introduction - Gramps Web
and on google

1 Like


This would have been a difficult one to find.

There are experiments going on right now with an interface to the Plugin Manager to make finding documentation for add-ons more consistent & easier to locate.

But this a not an add-on , it is a alternate interface for the Gramps tree database. It is not yet linked in the “Web Solutions for Gramps” wiki page either!

So, other than that search here on Discourse, I do not think there was another option other than asking.

How do you think your Web API should be added to the Web Solutions for Gramps wiki page?

It isn’t a plug-in but it is an add-on. How do we add it’s listing to the third-party add-ons page?

It seems like it would need a wholly different outline header and, if it installs in pieces, possibly multiple entries under that heading.

Honestly I find this answer really frustrating as I opened the pull request almost 4 months ago! The way we release addons in Gramps is broken if you ask me.

It is! Section 2. Quite prominent.

Since the plugin was downloaded from Github, opening an issue on Github might have been another good option. After all, I only learned about this post here when somebody else @mentioned me just now.

1 Like

You’re right about the mention on the wiki … and its placement. But the listing doesn’t ‘pop’. Do you mind if I add your illustration:

It’d be good to see a few more adopters giving feedback on set up.

(I just watched vid introducing ‘Mastodon’ social media alternative to Twitter… which sounds like IRC with prettier front end to me… and the big complaint is the same with most new tech: the install & setup hasn’t yet evolved for dazed & confused 1st timers. Your project seems to be at that stage too. So more grist for that mill would push towards a finer product.)

1 Like

There isn’t really a process for releasing addons. In the past we have left it to individual developers. The actual publication of an addon has to be performed by a trusted developer. This is to guard against malicious code.

I’m currently working on a new Addons Manager and a new presentation for addons in the wiki. We could also consider suggestions to improve the release process.


@kombatt I just pushed a workaround that might make it work for you:

Can you please try again with the current version in the master branch?

Hi @DavidMStraub ,
first of all thanks for your work

I managed to make it work adding typing.py in the folder

as you asked I’ve now downloaded and tried again, plugin is not loaded with this error:
‘type’ object is not subscriptable

if we need to manage this somewhere else (proper bug tracking) let me know

Can you try now please? Tried another fix

1 Like

addon is loaded correctly now, thanks

1 Like

Now that your changes have resolved his issue, could you please push a new 1.0.1 version increment? It will help future troubleshooters if we can mark this Help thread as ‘Solved’ where the posting includes a version number.

Done. Also updated the pull request.

again I’m not sure if this is a bug or I missed something configurating Gramps Web
(I used digitalocean droplet)
when running Web Sync it stop on step 5, after successfully syncing objects,
on synchronize media files it says

8874278: ERROR: grampsapp.py: line 174: Unhandled exception
Traceback (most recent call last):
  File "C:\Users\Kombatt\AppData\Roaming\gramps\gramps51\plugins\WebAPISync\webapisync.py", line 230, in prepare
    self.files_missing_remote = self.get_missing_files_remote()
  File "C:\Users\Kombatt\AppData\Roaming\gramps\gramps51\plugins\WebAPISync\webapisync.py", line 489, in get_missing_files_remote
    missing_files = self.api.get_missing_files()
  File "C:\Users\Kombatt\AppData\Roaming\gramps\gramps51\plugins\WebAPISync\webapihandler.py", line 120, in get_missing_files
    with urlopen(req) as res:
  File "AIO/urllib/request.py", line 223, in urlopen
  File "AIO/urllib/request.py", line 532, in open
  File "AIO/urllib/request.py", line 642, in http_response
  File "AIO/urllib/request.py", line 570, in error
  File "AIO/urllib/request.py", line 504, in _call_chain
  File "AIO/urllib/request.py", line 650, in http_error_default
urllib.error.HTTPError: HTTP Error 500: Internal Server Error

Ok, I just realized that database on digitalOcean has my PC local path.
I did API get https:///api/media/ and I see all the media with the same path.

 "mime": "image/jpeg",
    "note_list": [],
    "path": "OneDrive\\Documenti\\Albero genealogico\\MEDIA\\001.jpg",
    "private": false,

Maybe API Sync addon is stopping since it cannot find actual media files?
Do you have any suggestion on how I can manage my media files?

ok I think I “resolved”

I removed all media file from local gramps, then I removed all media from gramps web using API
DELETE /media/{handle}

then I added file on local gramps and let it sync and load