Apple Silicon 5.1.5 Version M1 Mac program won't start after going to maps

MacBook M1 Air, MacOS Ventura 13.1, Gramps latest * [Apple Silicon 5.1.5]

After clicking on maps in program the program crashes and won’t restart. Error message when trying to load the program: Gramps quit unexpectedly. and then crashes with standard Mac OS report error message or ignore.

Tried dragging to trash and re-installing as virtually nothing was done yet with the program but it results with same error. Had used Gramps before going to M1 Mac but this is a brand new tree nothing but a handful of names but won’t start.

How do I start over?

I was able to load the same version but for Intel over top and break lock to get back the program as Intel based but M1 version but native Apple Silicon 5.1.5 doesn’t work on my Apple Silicon Mac. Rather odd? Anyone else having this program?

The .ini files are in the Gramps User Directory. Reinstalling does NOT clear those files.

However, for testing, you might want to try starting in safe mode.

I will see if I can get safe mode from Mac Terminal and see what happens instructions though appear to be for Windows machines I’m on an M1 Mac currently the intel based version works using Rosetta.

Didn’t need to go into safe mode apparently installing the Intel version running it and then reinstalling Arm based version but keeping both copies did the trick. Program back work.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.