wxETI for metadata exploration in Windows

Place holder to support a Discourse thread for an application for services complementary to Gramps.
wxETI is a wxWidget based Utility for adding a Windows OS interface to ExifTool by Phil Harvey.

ExifTool is a platform-independent Perl library plus a command-line application for reading, writing and editing meta information. ExifTool supports many different metadata formats including EXIF, GPS, IPTC, XMP, JFIF, GeoTIFF, ICC Profile, Photoshop IRB, FlashPix, AFCP and ID3, Lyrics3.
ExifTool is also available as a stand-alone Windows executable and a MacOS package: (Note that these versions contain the executable only, and do not include the HTML documentation or other files of the full distribution above.)

Actually I do have a version which supports PDF, but since there has been next to no feedback on this utility - though that could have other causes - this app has been left in a bit of a questionable state as I have concentrated on other apps and issues.
Because it is a Win only app, I had tried to come up with a more portable wxPython version, which also is in a bit of a dubious state, though it is adequate for my current
At some point, I had the C++ version ported to Mint, but in both the C++ and wxPython cases, the final hold up is/was converting my setup to a package which can be distributed.
Right now, I am not quite ready for a public release of the source via Github or similar channels - if only to avoid the inevitable questions for support & mods…
Considering the lack of interest and the long list of other ‘rabbit holes’ to chase, I have left things as they were: usable and workable for my own use, if and when I need these facilities.

For Brian :slight_smile:
Please rename the attached *.gramps file & give it an extension EXE to reconstitute the actual installer. Best do so in a sandbox to be sure & safe.
Also note that much of the navigation to files needs to be done via the File menu item until I get a chance to fix the GUI navigation

Have a good Christmas

wxETI- attachment (7.8 MB)

Thanks for the installer executable in this renamed ZIP.

Installing (to a sacrificial Windows laptop) has an error:

Runtime error (at 4:220):
Internal error: Unknown custom message name

Private Messaging in Discourse also allows attachments. So we can exchange dangerous attachments there instead of publicly in the Forum.

Probably some dependencies are missing - most likely my systems have them all already. Will have a look.
Does that error show during installation? or when it is trying to start?

But I’ll probably have to stick with changing the extension; I’d be very surprised if the forum would not also check for private messages.

Does that laptop p[erchance have an old version of wxETI installed ?

During installation. Installation fails and aborts.

No, it is a freshly restored from the restore partition. But I can download that 0.1.138 32-bit installer from your wxutils.com wxeti page and try again.

Also note that this app needs exiftool.exe installed somewhere on the path.
The app looks for it but it may misbehave if it cannot finds it in the places it looks for

If you can install and run the 32-bit installer, I probably should post a 32-bit version to see if that works

Hold everything.
In my rush to get things going for you, I posted an old & likely unstable version.

Will need to take a bit of time to regroup and find out which is which.
My apologies for the wild goose chase.

Foiled again, the new version is just too big > 8MB :frowning:

Using 7Z worked - this time replace the extension with 7z and the unzip it
keep me posted :slight_smile:

wxETI- (7.8 MB)

1 Like

No Joy. Same error with renamed to, extracting the.gramps succeeded. Renamed

Downloaded the exe (had to change the link from a http:// to a https:// to keep the browser from complaining) and running that installer gives a different error.

Runtime error (at 31.140):
Internal error: Unknown custom message name

Continued despite the error.

then failed because it needed to downloaded files from download.microsoft.com and the machine is not connected to the net.

That last error is very likely because it would/is expected to try and download the Windows run-time libs/dlls.
Never have tried to download to /install on a ‘floating’ PC.
All of my test PCs live on my LAN

The earlier errors, I have no idea - what version of Windows are you using to try and install it?

hmmm. The report dropped a whole series of error messages.

(I had to swap the ethernet cable to the isolated PC and forgot to switch it back to this machine. Discourse doesn’t handle that well!)

I am installing onto a Win10 Pro 64-bit version 22H2 ThinkPad (OS build 19045.3324 installed on 17 Dec)


Just tried it all on my end.
Copied the gramps file to a local PC, also running Win 10, 64-bit. disconnected it from the LAN and rebooted to be sure.
Renamed the *.gramps file to *.7Z, unpacked it to get a new *.gramps file.
Renamed the new *.gramps to *.exe
and then ran the *.exe without a hitch - installing for all, which will try to create a directory in
Since it can’t find exiftool.exe where it looks for it, it pops up a dialog to say so which includes a button to locate it yourself, if it is already somewhere on your PC.
Else, you’ll have to install it and then, if it is on the path, wxETI ought to find it; otherwise it is supposed to give you another chance to find it for the app.

Going to restore the PC to baseline. Then will install to a virgin system with an ethernet connection to the net.

Should I do the wxETI- (7.8 MB) or the 0.1.138 32-bit installer ?

You could try either, but if it works, it might be best to try the current version
I don’t recall off hand when PDF came into the picture for this app

The big thing I was missing was to first install ExifTool and then reboot.

Good to know, assuming it now runs? :slight_smile:
And have a merry Christmas