Updated w/ screenshots Gramps does not recognize fontconfig is installed

As stated in the " Is there a way to specify an empty symbol?" thread. my computer crashed and I had to reinstall Ubuntu 20.04.1
Now Gramps simply does not work properly. first of all it says fontconfig is not installed. I have verified and re-verified, it is in fact installed.

also a fresh Ubuntu 20.04.1 install does not have a usr folder and there is no symbol.py file on my computer, so any ideas on how to fix this. Gramps is not usable with symbols for me. Too distracting and too hard to remember what they all mean.

Any ideas? I can not figure out why it will not recognize fontconfig. does it just not work with Ubuntu 20.04.1? I am running gramps 5.1.2

Ok, I deleted 20.04.1 and reinstalled 20.04
no change.
I have no idea what to do next.
90% of my time is spent on my family tree. I am totally lost. I tried running both Legacy and Roots Magic in wine but the functionality is just not there. I really need my gramps back. Please help

If I revert back to Windows (probably Windows 7) will I be able to edit that file and get rid of the symbols? (I really hate the idea of giving up linux to go back to windows, but I have to do something)

I think you’re not getting replies because the problem description doesn’t sound accurate.

I can’t imagine a situation where Gramps would be running without a user directory.

Why don’t you do some diagnostic & post the results? Like running the Prerequisites Checker in the Dashboard.

this is the Ubuntu wiki that explains usr is no longer used NOTE: I did what it suggests in this screen shot and it made no difference

as for gramps and the fontconfig…
fontconfigfrom 2020-09-11 01-18-37

prerequisites…
Diagnostic Gramplet to help evaluate if Gramps has all prerequisites installed.

You have Gramps 5.1.2. Please make a backup and then upgrade.
Gramps 5.1.3, is the most current version.

REQUIREMENTS
The following packages MUST be installed (Requires the minimum version or greater.):

  • Python 3.8.2 (Passed: version 3.3.0 or greater installed.)
  • GTK+ 3.24.20 (Passed: version 3.12.0 or greater installed.)
  • PyGObject 3.36.0 (Passed: version 3.12.0 or greater installed.)
  • Cairo 1.16.0 (Passed: version 1.13.1 or greater installed.)
  • Pycairo 1.16.2 (Passed: version 1.13.3 or greater installed.)
  • Pango 1.44.7 (Passed: version 1.29.3 or greater installed.)
  • PangoCairo 1.0
  • Berkeley Database library (bsddb3: 5.3.28) (Python-bsddb3 : 6.2.7)
  • SQLite Database library (sqlite3: 3.31.1) (Python-sqlite3: 2.6.0)
  • xdg-utils (Manual check see instructions link)
  • librsvg2 (Manual check see instructions link)
  • language-pack-gnome-xx (Manual check see instructions link) for your Language

STRONGLY RECOMMENDED
The following packages are STRONGLY RECOMMENDED to be installed (needed for geography and charts):

  • osmgpsmap not found (Requires version 1.0 or greater)
  • Graphviz Graphviz not in system PATH
  • PyICU not found(ICU not found)
  • Ghostscript 9.50
  • python-fontconfig not found, (Requires version 0.5.x)

Optional
The following packages are optional:
Gtkspell enables spell checking in the notes.

  • GtkSpell 3.0 (Passed: version 3.0 or greater installed.) (enchant module: not found)
  • rcs installed TBD (Requires version 5.9.4 or greater installed. If not on Microsoft Windows)
    Python Image Library (PIL) is needed for cropping images and LaTeX output.
  • (PILLOW 7.0.0)
  • GExiv2 : not found (Exiv2 library : not found)
  • geocodeglib not found (Requires version 1.0 or greater installed.)
    For addon Networkchart, font White Rabbit provides an extremely readable result.
  • Installed font: found another font

screenshot of fontconfig install

If there is anything else I can get for folks to see, let me know

edit - here is home folder

1 Like

Thanks.

I’m hoping this more structured info will prompt one of our users who is familiar with Ubuntu to post. (Although we may need to re-post to the maillist where there is a MUCH larger audience than this new forum.)

I did see that several installers & add-ons had been tweaked for the 5.1.3-2 installer. But that might just have been because the Windows version had problems.

(And I’m really looking forward to the Symbols expanded configuration options targeted for the 5.2 version.)

do you have any idea when 5.2 might come out? oh and I took one more screenshot to prove there is no usr file on my machine and gramps is working fine, just has symbols

You keep writing ‘usr’… but isn’t that the placeholder for your login Username? And that makes me think that what you’re thinking of might be the User directory. But the Symbols routines are in with the Program files rather than the User files.

For my Windows system, the file is in Program Files path at:
C:\Program Files\GrampsAIO64-5.1.3\gramps\gen\utils\symbols.py
and, for reference, the gramps executable is a bit higher on that path at:
C:\Program Files\GrampsAIO64-5.1.3\gramps.exe

In linux it is in a seperate folder from the .gramps folder…the path is

/usr/lib/python3/dist-packages/gramps/gen/utils

edit, I actually have the utils folder saved as a backup in case I messed up my symbols.py file

For files like this (where I’ve hand-patched), I put backup copies in as pre-formatted Notes in my Tree. They’re less likely to be lost.

Also put in a dummy Media file then edit its filepath to the Gramps file and attach the Note to that Media file. I have a dummy Gramps Person where the Media files are attached.

I don’t use Ubuntu, so I’m not up with its quirks.

A couple of things …
The ubuntu wiki screenshot you’ve shown is talking about the python application, It’s not saying that usr is not used, it’s saying the python application is changing. This is the change from python2 to python3. Gramps uses python 3. I’d be installing the python-is python3 package.

The /usr folder is a system directory, it contains a lot of applications that Linux cannot do without.
usr is not the same as /usr ; Note the preceding forward slash.
Your GUI file search is looking for a file or folder named usr in the current directory (possibly your home?) Change that to /usr and you will see it still exists.

I believe genealogical fonts are part of (were available of) texlive: texlive-fonts-extra

The gramps requirements that you list shows that it is missing (or strongly recommended) to have python-fontconfig,
Try and install python-fontconfig, if that doesn’t work try python3-fontconfig

For fontconfig, have you tried the GUi package installer (Synaptic ?) to find fontconfig and all its variations. It may explain / show why its being quirky

what I typed didn’t make sense so I deleted it. I might try that in the future if I can use it again. (I do know that technically I CAN use it now but I simply do not like the symbols)

Thank you very much for trying to help. but Ubuntu no longer uses a usr a file. it simply does not exist on my system. the screen shot I included of the search including searching the entire computer including hidden files. Ubuntu 20.04.1 did away with that.

edit to add…I included a screen shot of my system saying fontconfig was already installed on an above post

this is what I get when I use your suggestion of /usr

it simply no longer exists on Ubuntu

That’s weird. Maybe they are doing something unusual with permissions?

Open up a terminal and type
ls -l /

then try
ls -l /usr

If you still get nothing, put sudo in the front of them.

me@me-Latitude-E5510:~/Desktop$ ls -l /
total 2097232
lrwxrwxrwx 1 root root 7 Sep 10 21:43 bin -> usr/bin
drwxr-xr-x 4 root root 4096 Sep 11 00:38 boot
drwxrwxr-x 2 root root 4096 Sep 10 21:47 cdrom
drwxr-xr-x 20 root root 4460 Sep 11 03:10 dev
drwxr-xr-x 131 root root 12288 Sep 11 00:33 etc
drwxr-xr-x 3 root root 4096 Sep 10 21:47 home
lrwxrwxrwx 1 root root 7 Sep 10 21:43 lib -> usr/lib
lrwxrwxrwx 1 root root 9 Sep 10 21:43 lib32 -> usr/lib32
lrwxrwxrwx 1 root root 9 Sep 10 21:43 lib64 -> usr/lib64
lrwxrwxrwx 1 root root 10 Sep 10 21:43 libx32 -> usr/libx32
drwx------ 2 root root 16384 Sep 10 21:43 lost+found
drwxr-xr-x 3 root root 4096 Sep 10 22:02 media
drwxr-xr-x 2 root root 4096 Apr 23 03:32 mnt
drwxr-xr-x 3 root root 4096 Sep 10 22:11 opt
dr-xr-xr-x 236 root root 0 Sep 11 01:46 proc
drwx------ 4 root root 4096 Sep 11 01:01 root
drwxr-xr-x 35 root root 900 Sep 11 02:10 run
lrwxrwxrwx 1 root root 8 Sep 10 21:43 sbin -> usr/sbin
drwxr-xr-x 10 root root 4096 Sep 11 01:00 snap
drwxr-xr-x 2 root root 4096 Apr 23 03:32 srv
-rw------- 1 root root 2147483648 Sep 10 21:43 swapfile
dr-xr-xr-x 13 root root 0 Sep 11 01:46 sys
drwxrwxrwt 21 root root 4096 Sep 11 03:34 tmp
drwxr-xr-x 14 root root 4096 Apr 23 03:34 usr
drwxr-xr-x 14 root root 4096 Apr 23 03:42 var

and then

me@me-Latitude-E5510:~/Desktop$ ls -l /usr
total 120
drwxr-xr-x 2 root root 45056 Sep 11 00:21 bin
drwxr-xr-x 2 root root 4096 Apr 23 03:35 games
drwxr-xr-x 40 root root 4096 Sep 11 00:14 include
drwxr-xr-x 123 root root 4096 Sep 11 00:17 lib
drwxr-xr-x 2 root root 4096 Apr 23 03:32 lib32
drwxr-xr-x 2 root root 4096 Apr 23 03:32 lib64
drwxr-xr-x 12 root root 12288 Sep 11 00:21 libexec
drwxr-xr-x 2 root root 4096 Apr 23 03:32 libx32
drwxr-xr-x 10 root root 4096 Apr 23 03:32 local
drwxr-xr-x 2 root root 20480 Sep 11 00:20 sbin
drwxr-xr-x 256 root root 12288 Sep 10 22:41 share
drwxr-xr-x 7 root root 4096 Sep 11 00:20 src

so, using that I hunted again, still can’t find my symbols.py file

Okay /usr exists

What’s the file you are looking for?

Something in …
/usr/lib/python3/dist-packages/gramps/gen/utils
?

symbols.py file is the one

I can’t find symbols.py on https://packages.ubuntu.com

so what supplies symbols.py
What’s it used for?
Do you have a backup copy of it?