Is there a way to specify an empty symbol?

(Gramps Windows 10)

I wish to don’t have symbols for births and marriages.
I tried putting empty strings ("") in as shown in the documentation:

But this causes different problems in the charts.
For example in Graph View (the one i often use) some elements become unreadable.
Some charts don’t seem to take the file into account but use the symbol configuration in Gramps preferences if used (otherwize they use their own symbols).
Others seem to use a space (" “) instead of an empty string (”") but that’s not really what I would like visually (it is also the case I think if we put “nothing” for “death” symbol in the Gramps configuration).

So is it possible to set an empty symbol or definively not ?

Thanks for your help.

Best regards.

There will be change giving users greater control over the use of symbols in 5.2. I do not know how or where but @SNoiraud has been working on it.

But for the here and now.

Gramps is looking for a symbol, so give it one. Try \u202f. According to my character map it is Narrow No-Break Space. It seemed to work in my small test and I did not change all of the possible symbols. I did some more scrolling in the character map. \ufeff says it is Zero Width No-Break Space.

Remember, you are giving Gramps a Symbol so the Preferences “Use Symbols” will need to be checked.

I just came here to ask a very similar question. I know how to get rid of the symbols usung the file however, my computer crashed and I had to reinstall Ubuntu 20.04.1.

I was already using this version, I had upgraded to it from Ubuntu 20.04.

Well,…a fresh install does not have a usr folder and there is no file on my computer, so any ideas on how to fix this. Gramps is not usable with symbols for me. Too distracting and too hard to remember what they all mean.

Many thanks for your answer.

I would have liked to test and answer you earlier, but now I have a problem with Preferences-Symbols.
I had started testing and at some point the character was not showing.
I then thought it was a font problem and I went to Preferences-Symbols to do a “Try to find” again.
By doing this it found nothing and since then I can no longer check “Use symbols”.
I’ll come back later to say if it works when I fix this problem.

On the other hand, when it still worked, I had done a test by putting Nothing for Death in Preferences-Symbols and the Graph View display was corrupted.

Either way it’s a good idea to try other characters.
I knew nbsp but I was far from imagining that there were unicode variants you are talking about.
\ ufeff tempts me a lot :slight_smile:

Also glad that symbol handling will be improved in 5.2.
I tell me on this subject that it may be necessary to consider being able to define them according to the context, text or graphic.

Best regards.

Since you are on Win 10, I used the Window’s Character Map tool. I normally only search DejaVu Sans. I use it in my Themes tab and it is the font I used to select my symbols.

The symbols information is stored in the gramps.ini file stored with your user files.


At the bottom of the file will be

available-fonts=['DejaVu Sans Condensed', 'DejaVu Sans', 'Segoe UI Symbol']
selected-font='DejaVu Sans'

This from my file. Check to see what yours says. Deleting what is there (while Gramps is closed) may let you start fresh.

Thanks, thanks to that “use symbols” is checked again.

I first tried removing the [utf8] entries from gramps.ini but it didn’t work (there was only “death-symbol = 12” in it).
Then I copied the entries you posted and it works.
I wonder if the problem didn’t appear because I clicked on “try to find” when “use symbols” was checked.
I probably won’t have time for further testing today but thank you already for this part.
I will come back when I have done the other tests for the empty symbol.

Best regards.

1 Like

I have done several tests (with the characters you mentioned and others) but I cant get what I want.
Charts that use preference / symbols / use symbols seem to reserve a place for symbols.
There is therefore a way to not display the symbol but not to “delete” the space it occupies.
I believe we have to wait for the evolution of the development of these addons and the symbols management in Gramps.

For symbols managment I wonder if the possibility of being able to add a string before and after the symbol would not be interesting too.

Thank you again for your help.

Best regards.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.