Gramps configuration: genealogical symbols

Been watching this on the email list with great interest. I do not like the symbols. not even a little bit. they don’t work right on my machine. I actually uninstalled the new version because I hate them so bad. With all the talk in the email list of stopping support for the older version, I figured I had to go ahead and use new version. It works great - except those symbols Honestly, I wouldn’t care if the symbols did work. I still would not like them. they are ambiguous and i have to refer a hundred times a day to the list of what they mean because none of them make any sense at all. Please, Please, there has to be a way to give the option to use them or not. Please give us the option to go back to what was easy to understand without being some kind of computer guru.

All these symbols are standard and used by many programs. I didn’t invent them.

I understand you don’t like them. This is the reason for a new PR for genealogy symbols enhancement:


You’ll need to wait for 5.2 for that.

2 Likes

ok, not sure what some of that means - but I understand the wait part. I’ve never seen those symbols and I’ve been tracing my tree for over 30 years. Will the next release have the option to not use the symbols and go back to the way it was?

Looking at the change, yes, an option to use strings (text) will be in the change.

If you do not want to wait, you can edit the file that sets the symbols. The file is in your program folder.

\gramps\gen\utils\symbols.py

There will be two sections that list the type of symbol, then the UNICODE and SUBSTITUTION for that symbol.

Editing the information in the SUBSTITUTION columns with your preferred text for each item will cause the text to be displayed instead of symbols when the “Use Symbols” is unchecked in Preferences.

1 Like

I will see if I can figure out how to do that. Thanks

I have done a search and even in hidden folders I cannot find this. Is this for Linux? I use Ubuntu 18.04

edit, I can find lots of .py files but not that one and cannot find that folder either

edit - found it!

ok, found everything, figured out how to edit like you said, but will NOT let me save. Says it is read only. Will not let me change permissions. What am I doing wrong

The program folders are protected.

Save the modified file to your desktop and then copy it back into the folder.

It is also always a good idea to save a copy of the original file anytime that you attempt a hack. It is easy to mess up and it is always easier to get back to the original and try again.

i tried that but i will try again

edit - thank you very very much for trying to help me

this is what I keep getting

Have you closed all instances of Gramps? and/or restarted your computer, a file can “hang” in system from time to time… mostly on Windows but I believe it can happen on Linux also…

Thank you for trying to help StolHD. yes, I had actually already done that twice, but I tried again just to make sure. just keeps saying permission denied, if I try to copy to or move to, does not matter. it just will not let me do it. Any and all help and/or ideas are very much appreciated

oh, and SNoiraud … I just reread my original post and realized I came off as rude. I did not mean to.

am I in the proper place???
Screenshot from 2020-03-30 02-25-27

and this is permissions screenshot

You must be root to do that. sudo ? what linux do you use ?

Ubuntu 18.04 is the version I use

Is there any chance that the Genealogical Symbols could be re-imagined as an Add-on instead of a built-in? The underlying hooks for the symbol functions probably needed to be in the core code. But locking down the interface was premature. A lot of its potential hasn’t been tapped yet.

Since the evolution of this feature is stuck in lock-step with Gramps releases, it could take years to get all the tweaks in place. At most, we see 2 releases a year. But add-on revisions could be released daily without causing a problem. It would make mistakes and experiments less stressful to manage.

Naturally, the development focus has to be on the primary functionalities… like being able to add the ability to choose more custom qlyphs than just death… or making the font-family selection not affect other parts of the Gramps interface. Or being able to select glyphs from different font families simultaneously. Or being able to increase the point size of the Glyphs independently from the data text. (The glyphs are illegibly small in comparison to the dates which are clearly readable.)

The other parts need adjustments too. But they’re likely to be ignored because the other stuff is more important.
Like the clutter of the Preview that shows languages that aren’t even installed in the Gramps application.
Or the ‘conversational’ noisiness of the dialog. The Genalogical Symbols tab contains more explanation and recommendation than any other part of the interface. It would be more appropriate if this verbiage was in the wiki. And the grammar needs proofreading. (Having a button labeled ‘Try to find’ is a very odd phrasing. There are missing words.)

These are typical growing pains for a new feature. It just needs more eyes and more opportunities to evolve & distribute revisions.

This feature also demonstrates that the URL called by the Preferences help button needs to be tab specific. The Preferences has grown too diverse to be using a single landing page.

a wiki page for hacking the Genealogical Symbols table has been started. It took the better part of a week to get it this far.

But it needs a lot of work. For each thing explained, it seemed like 2 more items needs to be explained. It still needs more information. I was able to put in info on the application folder for Windows. But Linux, MacOS (any of the POSIX OS flavors) paths have to be contributed by other users. And perhaps URL pointers to managing hidden files & user permissions for various OS could be gathered. We shouldn’t try embed those file management processes in the wiki but point people to good net articles is reasonable.

Perhaps you should start from the PR 996 instead of what you have in 5.1

1 Like

I just got this in my email this morning.

An example that the symbols ARE being used.

marker