Gramps development in Windows using msys2

I had been contributing to some Gramps addon development few years back, but then had given up due to Gramps using another way to compile under Windows.
I now wanted again to try some modifications/feature development, so I reached out to the manuel to install Gramps on msys2 on my Windows platform. However, following Gramps for Windows with MSYS2 - Gramps, I ran into some issues. I already started to update the Wiki page based on my findings during the process, however, the following issues are still unclear (more might pop up in the following steps):

  • There was an issue with Graphviz; it is resolved? The URL ( provided in the manuel returns a 404.
  • When following the instructions on this page, I run into the following error when executing this code “python3 install”:
    gcc -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -march=x86-64 -mtune=generic -O2 -pipe -march=x86-64 -mtune=generic -O2 -pipe -march=x86-64 -mtune=generic -O2 -pipe -I/usr/include/python3.10 -c fontconfig.c -o build/temp.msys-3.3.6-x86_64-3.10/fontconfig.o
    fontconfig.c:235:10: fatal error: fontconfig/fontconfig.h: No such file or directory
    235 | #include “fontconfig/fontconfig.h”
    | ^~~~~~~~~~~~~~~~~~~~~~~~~
    compilation terminated.

Some support would be needed to get started (again).

I have not tried to recreate or update my msys2 newest libs environment in a year or so so I cannot really help you with these issues. I will note that every time I do it, I get problems like you are experiencing, and then get to spend time trying to figure out how to get past them.

I’d guess that to deal with the missing fontconfig.h, you will have to download a relatively recent source for fontconfig. Which makes fontconfig a prerequisite.

I don’t recall having any special issues with Graphviz the last time I updated. Looks like it is pretty up to date as last update was June this year.

Thanks for the response. Yes, looks like the graphviz issue is resolved. I have updated the Wiki page accordingly.
I was fearing that Wiki manual would need constant updates as things change frequently… :frowning:

I think I managed to do all preparatory steps. Now running into two issues trying to run Gramps:

  • .gramps.gen.utils.grampslocale.WARNING: ICU not loaded because No module named ‘PyICU’. Localization will be impaired. Use your package manager to install PyICU
  • Deine Version von gi (gnome-instrospection) scheint veraltet zu sein. Du benötigst eine Version mit der Funktion ‘require_version’ um Gramps zu starten

I remember that I had additionally installed “python” and “python-setuptools” during the preparation steps, as there had been the error “-bash: /usr/bin/python3: No such file or directory”. I have now uninstalled those two packages and re-installed the packages described in the manual, i.e. “mingw-w64-x86_64-python3-cairo mingw-w64-x86_64-python3-gobject mingw-w64-x86_64-python3-icu”. However, unfortunately, I am now again experiencing the “-bash: /usr/bin/python3: No such file or directory” error as before.
I have tried adding C:\msys64\mingw64\bin to the system PATH and also added C:\msys64\mingw64\lib\python3.10 as PYTHONPATH in my Windows (according to some help I found on the Web), but that didn’t help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.