Re: [Gramps] [Announcements] Gramps 5.1.4 released

Thank you Nick and other developers who’ve worked on Gramps! I appreciate all of it.

Phil.

4 Likes

Thanks to all for the new release.

Will there be an install package (*.dmg) for macOS as well? Have not found it yet.

Thanks

@Nick-Hall has closed the code to changes for the version and posted the Source code to zip and tar.gz files. It will now take time for the volunteers that build the various installers.

Patience!

macOS installer is available now; direct link:

https://github.com/gramps-project/gramps/releases/download/v5.1.4/Gramps-Intel-5.1.4-2.dmg

1 Like

I just tried the macOS and I had issues.

  1. When I tried GraphView, I got no visible image (but error msgs in console). No matter how I configured the view (changing font, removing avatar, …), I still got no image and these errors. When I resized the view, I could see the horiz and vert scroll bars appear (as I zoomed in) and disappear (when I zoomed out). The error in console when I selected GraphView was:

dyld: Library not loaded: @rpath/libgvc.6.dylib
Referenced from: /Users/gary/Desktop/Gramps 5.1.4.app/Contents/MacOS/dot
Reason: image not found
2021-07-28 09:37:57.949: ERROR: grampsapp.py: line 173: Unhandled exception
Traceback (most recent call last):
File “/Users/gary/Desktop/Gramps 5.1.4.app/Contents/Resources/lib/python3.9/site-packages/gramps/gui/viewmanager.py”, line 873, in view_changed
self.__change_page(page_num)
File “/Users/gary/Desktop/Gramps 5.1.4.app/Contents/Resources/lib/python3.9/site-packages/gramps/gui/viewmanager.py”, line 884, in __change_page
self.active_page.set_active()
File “/Users/gary/Desktop/Gramps 5.1.4.app/Contents/Resources/lib/python3.9/site-packages/gramps/gui/views/navigationview.py”, line 153, in set_active
PageView.set_active(self)
File “/Users/gary/Desktop/Gramps 5.1.4.app/Contents/Resources/lib/python3.9/site-packages/gramps/gui/views/pageview.py”, line 338, in set_active
self.build_tree()
File “/Users/gary/Library/Application Support/gramps/gramps51/plugins/GraphView/graphview.py”, line 284, in build_tree
self.graph_widget.populate(self.get_active())
File “/Users/gary/Library/Application Support/gramps/gramps51/plugins/GraphView/graphview.py”, line 1431, in populate
self.bold_size, self.norm_size = self.fit_text()
File “/Users/gary/Library/Application Support/gramps/gramps51/plugins/GraphView/graphview.py”, line 1762, in fit_text
text_font = font_fams[0] + ", " + font_sizes[0] + ‘px’
IndexError: list index out of range

  1. At startup, the following warnings/errors in the console. I assume these are unimportant:

Could not find platform independent libraries
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to [:<exec_prefix>]

  1. When I selected Preferences, I got the following warning on console (I assume unimportant):

(Gramps 5.1.4.app:77492): Gtk- WARNING **: 09:41:20.325: Could not find the icon ‘missing-image-ltr’. The ‘hicolor’ theme
was not found either, perhaps you need to install it.
You can get a copy from:
http://icon-theme.freedesktop.org/releases

1 Like

New version (5.1.4-2) fixes this issue. Thanks for the fast response.