Private events filter


Can it be that this filter is faulty?

In the menu I select Events


Create the filter to view the events that are set to Private…

But the search result is empty ?

Greetings - Jan

(Gramps 5.1.3 Linux)

Mine seems to be working correctly. But there may be some confusion regarding which lock is being searched.

When adding/editing an event for a person or family,two locks are shown. One lock is in the shared portion of the event reference editor. Red in attached screenshot. This is the lock when in events, the filter rule “Events marked Private” will find. In a person’s event list, this lock does not display in the list of events.

The second lock (green in screenshot) is the lock displayed in a person’s list of events. It is actually a part of the People database and not searchable through the event list.

I know, a little confusing. There was an earlier thread that discussed the two locks in displays.

You might try a simple test. Temporarily mark an event record Private then run your filter to see if it is returned in the filter.

Tested with the example.gramps sample tree. It also showed no Private Events.

But that was correct. There were some Private Notes but no Events (or People) set to ‘Private’

As a test, I set a Person and an Event (of a different Person) to Private. Now clicking the ‘Find’ button in the filter Gramplet gave the correct results. The filter found the Private Event… but not the Events of the Private Person. (Events of a Private Person are not explicitly Private.)

Here is a different way of checking for Private Events:

Configure the Event view to show a Private column:

Select the Events View from the Navigator
Select the ‘Configure’ button from the toolbar
Enable the Private checkbox
Drag the Private Column Name to the 2nd from the top of the list (which will make it the 2nd column)
Click the Apply button
Click the Close button
Reset any filters
Click Find to show the unfiltered list.

Now, you can click the Private column title to sort on that criteria.

All the blanks will be at the top of the list. So scroll to the bottom; or, click the column title again to reverse the sort order

If there are no padlocks in the Private column for any row, there are no Events explicitly set to ‘Private’.


You are right @DaveSch! That would have been worth a try. However, I assumed to have safely marked some events as private … which was not the case :wink:

And so the events which are marked as private are also listed!

However, I have some entries for people who are e.g. godfather or witness in the upper area of the input window marked as private … and I wanted to have them listed. Which I can do but for example also about a filter to the role.

@emyoulation Thank you! That was new for me!

Thank you for the useful tips!

Greetings - Jan

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.