Place name in relationship graph


i just just the gramplet “Place Cleanup” to geocode my places. That has worked fine and places have been organized. So i have some groups now which contains several places. Nice to have.

But when i generate the relationship graph now Gramps does not only take the place but also the group name. Could be something like “USA, West Coast, California - Los Angeles”. This messes the the whole graphic up. I would like it to use only the place name “Los Angeles” instead.

Is there any way to archive that besides deleting all groups again?

PS: Thank you for this great programme!

Welcome Magnus

With the next major release of Gramps (5.2) there will be greater control by the user in how place names are displayed.

But there are some some things you can do today.

If you have “West Coast” between “California” and “USA” you can do away with that as a hierarchy level. California should be directly below USA. You may need a “West Coast” under USA to account for that relative that went “West” and the actual location or state is unknown. All you know is that they went to the West Coast.

In the Display Place Editor found in the Preferences Display tab you can create different display options. Remember, any setting will apply to all displayed place names.

One option is to create a Format “City”. In the Levels field put p0 This will display just the populated place name. (City/Town/Village/Hamlet). p0,-2 would display the City, State for places in the U.S. where the hierarchy is Country, State, County, City. These settings are convenient for graphs where place names can get very long and will skew box sizes.

This is also where you set which order to display “Number Street” or “Street Number”. Right now these are applied universally but as I mentioned, the next major release will allow this setting by country.

This is also where you set which order of places are set. Smallest to Largest or the reverse display order Largest to Smallest.

Hope this helps.

Thank you!

I used the Display Place Editor with the p0 format. That works fine. The feature was too well hidden for a beginner :slight_smile:

I am looking forward to the next release.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.