Media when exporting to Ancestry

I am trying to export my GedCom into Ancestry. That works but the media doesn’t come over.

The GEDCOM 5.5.1 standard only embeds links to multimedia, not the actual file.

The 5.5 version had support for encoding multimedia in hexadecimal form as part of the file. (See Appendix E) But that feature was eliminated in the defacto 5.5.1 standard. It made HUGE files that were too unmanageable for the data storage media of the time.

While Gramps has a GEDCOM Extensions export that supports the Appendix E variant of the GEDCOM 5.5 version, very few programs support importing it today. (It was only a valid option from 1996 to 1999.)

You would want to determine if Ancestry accepts that format. I would try a test (filtered to a single Person who has media attached) before investing the time with a huge & comprehensive Tree.

Thanks. I tried that extension for GED2. Renaming the file is the only way Ancestry reads it but the data doesn’t get imported.

I’m using Root Sync to do it. Still a faff to delete the tree each time but mine is public and I don’t share via links anyway so it should work.

1 Like

Could you export a single person with media from Ancestry to GEDCOM? Perhaps a sample could help us determine the incompatibility.

It could be something simply like forward slashes versus back slashes. Or more ugly… like the scope of supported media types being different.

Since you’re renaming the file to get anything to import at all, it might be expecting one of the other extensions mentioned… like the .gedz extension.

I can’t attach the file itself so I’ve tried adding a screenshot. I’ve tried relative paths, etc., and that doesn’t help.

I think this is a standard’s issue in that the file paths are noted in the GED but the files are not held within, so Ancestry has no idea where the files are.

I was actually suggesting an example downloaded from Ancestry. (What they export is likely to be what they expect to import.)

That screen capture looks like what you’re trying to upload. And, from just a glance, it also looks like it was a standard GEDCOM 5.5.1, not a sample of the .ged2 file generated by the GEDCOM Extensions export.

And, you are right. You will not be able to ‘upload’ anything but images here. This is just a discussion forum. We can help to diagnose but not resolve an actual bug. You would have to create a bug report to make something actionable. Bug reports allow other file types to be attached. (Please keep attachments small as possible while still showing the problem. Wading through excessive data makes fixing bugs more unpleasant.)

I’d tried that and got a similar result - it shows a web link within Ancestry when added to it manually and downloaded.

It is a standard GEDCOM, hence the issue. Ancestry doesn’t seem to support GED2, though that also exports exactly the same content even though media is selected.

I can import via other means. This seems to be a limitation of Ancestry only allowing the basic GED files and nothing extended. A pain since people commonly move data between systems but that is their limitation and not Gramps. I’m sticking with Gramps as I find it powerful, just have to upload via another program.

I’m not an Ancestry member … so I do not have access to their support areas. However, it is likely that they have sample files used as benchmarks.

I’m sure that info would be available to developers too. But to become a developer for Ancestry or FamilySearch, you have to sign an agreement. Even if the GrampsProject had incorporated to give the ability to make binding agreements, the terms conflict with the open source licensing. I do not ever see an official data scraper or uploader for any of the commercial services. (That sort of thing would have to be done by an independent. And released as a 3rd Party Add-on.)

Bottom line is that any Gramps support for Ancestry will have trial-and-error. With actual Ancestry customers combing through the public support information to pass along.

As far as I know, it is not possible to upload bulk media to ancestry via GEDCOM or its associated tools. It is possible to do this with Family Tree Maker, and RootsMagic, and probably a few others. They support Ancestry’s ‘TreeSync’ protocols. I think it is possible to get a trial version of one of these; that may allow you to do an upload via sync.

Unfortunately Ancestry doesn’t support open source tools for their ‘TreeSync’ functions; they have nasty licensing rules, so it is unlikely that Gramps will ever be able to do this.

1 Like

I’ve got it working with a process of exporting GED from Gramps, creating a new Roots Magic file and syncing to a new tree. I did go for the purchased one as it isn’t expensive. However, re-importing to the same tree file causes duplicates and their auto merge doesn’t figure out matches where only basic info is missing. Also seems not to keep syncing automatically - you just manually edit the bits that differ and can probably bring new people in.

I like working in Gramps and having that as my source, then uploading to Ancestry. Makes it portable and far easier.

It was worth a shot anyway. The media side works with Roots Magic so having that as a copy tool works fine.