I am getting Square boxes in the entry boxes

  • MacOS 10.13
  • Gramps 5.1.5

I imported a sample database from MacFamilyTree.

The names is correctly displayed in the toolbar. But, the name editor is showing squire boxes. I believe these characters are unicode.

Image 2022-05-10 14-27-42(1)

I believe the characters are unicode. According to this, the first letter እ, for example, is supposed to be U+12Ax.

What is wrong here? What can I do to be able to write using Ethiopic script?

I would say that you might need a language pack, or that Gramps is missing a component, but doesn’t tell that on screen.

Can you use that script in other programs on that same machine?

Also, can you start Gramps in console mode? I don’t know how to do that on MacOS, but if you can, it might reveal what Gramps needs.

Yes, I am using it to write on a number of programs. All unicode aware programs accept the characters; including this forum:)

But, I don’t know how to start Gramps in the terminal either.

The terminal command is on our wiki:


And it seems to depend on how and where you installed Gramps. What you found is quite odd, because the name looks OK in the window’s title bar.

Yes, it is odd.
Starting Gramps from the terminal doesn’t make any difference. I am getting the same squire boxes.

The boxes look very similar to the screenshot on the wiki for Font troubleshooting: No text, just rectangles but your issue looks to be a partial font issue, no mention in the section how to fix on macOS, did you recently upgrade macOS?

Wikipedia mentions those boxes are Replacement character used when the fonts on your system have no Unicode code point for this symbol!


I think this is a font problem. The OK name is related to the window manager and all others are from gramps.
The window manager can use a type of fonts and gramps another one.

1 Like

I didn’t expect any change, but hoped that you might see a warning when you open the person window. Did you see any?

I agree with Serge that this may be a font problem, meaning that the font dat we use inside text boxes is not complete enough to display Ethiopic characters, so that the software switches to displaying rectangles with the unicode value. This is another thing than the example that Patsy showed, where the rectangles are all empty.

@Dellu can you attach a small export file, with a single deceased person, that shows the problem? I like to test that on Linux and Windows.

Thank you guys. yes, it appears to be an issue related with font.
I didn’t upgrade my system.
Re-installing the software doesn’t make any difference.

@Dellu that’s why I asked for an example that another user can test on Linux or Windows.

I asked that, because it’s clear that we use another font for text boxes than MacOS chooses for Windows titles, and changing the font used in text boxes may help, but is not easy for users. There may be a way to change it with a system setting, or an extra tool to change the fonts used in the themes that Gramps/GTK uses on MacOS.


Here it is: Dropbox - test.ged - Simplify your life

Patsy has pointed out a promising lead.

Perhaps the Font Family being used for the Name Editor is using a character point-size that isn’t included & is different from the titlebar’s point-size?

Some experimenting with a text editor in your macOS might help isolate the problem. Try copying that chunk of text to the text editor. If the text is rendered correctly in the text editor, then you know that Gramps is writing the Unicode values properly… this is a display problem, not a corruption.

Then play with the text editor’s point-size controls. Maybe you can get those blocks (that look something like tiny “dominos”) to re-appear outside of Gramps.

You might want to experiment with a larger point-size using the Gramps Themes add-on.

WE already know that it is not corrupted because the characters are correctly displayed in the toolbar. I can even directly type in there: still correctly showing in the tool bar.

Thank you for pointing out the themes. I am going to experiment with them.

1 Like

OK, I got the GEDCOM and all names display well in Linux and Windows, so it is a font problem indeed. And the easiest way to change fonts is the Themes add-on. And with changing fonts, I don’t mean changing the size, but actually choosing another font name (or family), maybe the font that MacFamilyTree uses, if you can find out about that.

I wanted to test this, to exclude the small chance that Gramps might mess up sending text from the database to the text boxes, and I can now exclude that.

Thank you for testing it out in the Windows and Linux dear @ennoborg. But, I don’t think the font family is actually the issue here because I have pasted texts using different Ethiopic font families: and I am getting the same results.

I have tried about 6 fonts that Ethiopic has, and all of them are generating the same result.

It looks like only MacRoman fonts are supported in the Mac version of the software.

isn’t there anyone else in this forum who uses Gramps in the Mac?

Just double-checking but… your Linux/Windoze test included looking at the (frequently overlooked) Name Editor dialog, correct?

I’m wondering if that module just didn’t have all the same Unicode support libraries implemented as other Object Editor dialogs? So the display problem might be isolated to a single editor. Or to the macOS fork of it?

I am using MacOS 10.14.6 with Gramps 5.1.4

All looks correct to me. I have the Themes plugin and no matter what font I switch to, it looks correct.


I think I am wrong on the MacRoman part: characters from a number of languages including Bengali, Pujabi, Myanmar, Tibetan etc are correctly displayed.

Only Ethiopic characters are failing.
05_10_22 at 06.35.20PM

Thank you.
Indeed, it is working on your mac.
I am going to install the theme plugin, and try.