Exception when try to generate Detailed Descendant Book report

Hi guys!
I’ve got yesterday the exception when was generating Detailed Descendant Book report. I’ve retorted it via the app. Could you check it pls? Thanks a lot.

PS: I can repro it and re-send again if you need.

What app, they don’t have one? All bug reports are added manually by yourself to the >> bug tracker.

The Gramps app proposes report bugs. Does it work this feature? I’ve reported the bug via Gramps app.

If you report a bug this way, and want to discuss it here, it helps a lot if you add a link to your report. Can you do that?

In this case, I visited the bug tracker myself, and found a report that was created by a user who seemed to identify himself as Peter Hewett.

Are you Peter Hewett?

I believe that is this person @hewettp for that report?

No, I’m [urchello ( Yurii Liubymyi ). Looks like the bug-report was not created automatically via the app. I’ve simply clicked the Next button.Looks like I had to copy message to clipboard and create the report manually.
Created it now: 0012859: Exception when try to generate detailed descendant book report - Gramps - Bugtracker – Free Genealogy Software

Hello Yurii,

OK, thanks. The situation was a bit weird, because your alias didn’t look anything like the report that I found, but the reported error is exactly the same. That’s why I asked. I was also suprised to see two persons speak about the same error, on the same day.

I’m trying to reproduce this in Windows 11, but I may need your help to find the right options. Can you describe the options that you used?



@ennoborg Sure, lets repro together
Below I’ve tried to translate all my options. They could be not the same in original English, but I think you will understand which options I mean…

@ennoborg maybe lets discuss in any chat to make it faster? Any what you have: Telegram, Viber, Whatsapp, Facebook…

OK, I understand that this is a different report indeed, so we may have two different bugs, or two different books using the same code.

I don’t like chat, because I’m autistic, but I will give you my email. And it helps if you’re able to start Gramps in English. There are ways to do that, but if you can’t, I will try to read the screens. I can read Cyrillic, because I had Greek at school, and spent a few weeks in Bulgaria.


@ennoborg looks like I’ve localized the bug a bit. Its on Tab4, option: skip repeating ancestors.

OK, thanks. I can interpret options by their position.

Quick question: do you see messages that Gramps is checking ascendants for all people in your tree? And does it then start pruning too? I see those messages in English, even though I run Gramps in Dutch. And they make running the report on my PC very slow, even though it runs on an AMD Ryzen 7.

My email is in a private message. You should see a notification about that.

1 Like

@ennoborg I sent you 2 videos. The second one shows that one only option causes the exception when it is turn off.

Thank you. I found one in my mail, and I can reproduce the error in Windows 11, using a subsection of my own tree.

The movie was a good idea, because it also shows that Gramps is doing all sorts of weird things that I even I don’t understand, like that pruning.

Can it be that the second video was too big? Can you tell what option that is, by referring to the screenshots that you uploaded here?

The second video was 14 Mb. I could re-send it but looks like you no need it anymore ))

Thanks, that’s it. That’s the fifth checkbox on the 3rd screen, a.ka. the middle one in the left column of your composition. The exception occurs when that box is NOT ticked, right?

I can reproduce this in Linux too now. See my comment in the bug report.

@ennoborg exactly! thanks a lot!

I came across this a few days ago, and reported it as bug 12857 [AttributeError: ‘DetailedDescendantBookReport’ object has no attribute 'report_app_ref.] For me the error occurred when the “index of names” option was selected on the include (2) tab.

1 Like