Combined view bug


I just tried creating a new tree and decided to follow the instruction.
When I selected the relationship view I got an error. I have tried creating a tree 3 times and always get an error trying that process.
I am using Windows 10 with Gramps 5.1.2, with the new Combined plugin installed.

Perhaps it might be a Windows thing.

  • Lionel

I was just filing this particular initialization bug when I re-read your message. It is related to trying to view a blank tree with no people. It fails when trying to set the Active Person because no people exist to be made active.

It is directly connected to initialization of the ‘Combined’ developmental Relationships view mode. However, change the selected view category & restart Gramps after seeing it reported. Can cause continuing Navigator & toolbar problems in the session.

I am on Win10 and Gramps 5.1.2

No errors.

Just to clarify, I have been using gramps for 3 years and have a family tree with ~6000 people, with no problems. I am using the Relationships (combined) view when adding to my family tree and it is great.
I wanted to add a small tree just for a side research and it was with this empty tree that I saw a problem. I tried to open the Relationships view to add the first person from there and it caused the error. I used the People view to create the first person and after that the Relationships view opens with no error.
I recreated the probem with another new tree.

Error text:
0251: ERROR: line 157: Unhandled exception
Traceback (most recent call last):
File “C:\Program Files\GrampsAIO64-5.1.2\gramps\gui\”, line 871, in view_changed
File “C:\Program Files\GrampsAIO64-5.1.2\gramps\gui\”, line 885, in __change_page
File “C:\Users\asus\AppData\Roaming\gramps\gramps51\plugins\CombinedView\”, line 175, in set_active
self.update_mru_menu(hobj.mru, update_menu=False)
File “C:\Users\asus\AppData\Roaming\gramps\gramps51\plugins\CombinedView\”, line 450, in update_mru_menu
nav_type = self.navigation_type()
File “C:\Users\asus\AppData\Roaming\gramps\gramps51\plugins\CombinedView\”, line 170, in navigation_type
return self.get_active()[0]
IndexError: string index out of range

Version details:
GRAMPS: GrampsAIO64-5.1.2-1
Python: 3.6.4 (default, Jan 23 2018, 13:17:37) …
BSDDB: 6.1.0 (6, 0, 30)
sqlite: 3.21.0 (2.6.0)
OS: Windows

Thanks, Lionel

Fortunately, this is a simple bug that has been isolated & reported. It only occurs with Trees that have no people yet or where the Active Person is not yet defined.

Thanks for the follow-up. It will go away before the Combined View moves out of Development and into general release.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.