Win 11 annoyance

Just ended up using Gramps on my Win 11 PC and there seems to be a dozen or more windows which pop up and close in rapid succession before the main screen comes up.

Never noticed this when am/was running under Win 10.
Is there something that I am missing, such as a configuration setting or …??

I have been using Gramps on Win 11 Pro and Enterprise since the Windows Inside versions come out (early beta) and never experienced anything like that.

The only annoying thing I have experienced from time to time is a command line window that opens in the background and doesn’t close down, but that is a rare situation and I have never figured out what actually is the reason for that.

If it is GUI windows, maybe you can try to update your graphic driver (not the one from Windows Update)… just a tip.

Using Gramps 5.1.5 and Win 11 Pro ( 22H2 released 7 days ago) myself I don’t see what you mention.

What version of Windows and Gramps are you using ?

That appeared once for me when initially setting up Gramps under Win10. It may have been related to using the Console Gramps to launch. (I like the extra feedback the Console provides.)

And since it was a fresh install, Gramps had to do the first Python compile and caching (generating all those _pycache_ folders) that makes the initial launch of Gramps so slow and subsequent launches so much faster. The console windows would appear during each cache generation… if the process took long enough. The windows don’t appear if your computer is fast enough generating the caches.

The PortableApps fork of Gramps instantly throws up a splash screen to distract users from any visible behind-the-scenes setup. We ought to take a lesson from them.

(GIMP 2.10 does a Splash screen… but they are VERY tardy in displaying that. They seem to have misunderstood the whole idea behind a splash screen. Users already will have become worried well before the placating progress bar appears:

We should take a lesson from their mistake.

Thank you all for your comments.@stoltHD
I have updated the graphics drivers for my MB video interface - no difference.
@daleathan Win 11, current update as of 5 min ago & Gramps AIO64-5.1.5-1

Just for the fun of it, I started Gramps and counted
2 windows before the main Gramps screen
6 windows before the dialog to load a family tree
4-5 after selecting a tree to load

This follows a double-click on a desktop icon linked to a target:
“C:\Program Files\GrampsAIO64-5.1.5\grampsw.exe”

FWIW, this is running on a Intel(R) Core™ i9-10900 CPU @ 2.80GHz 2.81 GHz
20 core, 16 GB of RAM, Win 11 Pro version 22H2

You could try to make a shortcut with this in the “target”.
%comspec% /c set LANG=en_US.UTF-8 && start grampsw.exe"
and you will also need to set the “start in” e.g., “C:\Program Files\GrampsAIO64-5.1.5”
(it’s another way of starting Gramps with defined language)

Also, try to run grampsw “as administrator”,
it can also be that if you have an AV software installed that it does something or did something “#R¤¤%#¤”“R”#%“%!” with your installation.
(i will deny ever using those kinds of phrases in public :rofl:).

You could also try start Gramps via the command line with the debug switch, I don’t remember how the best way is for this, but there are multiple posts on it here.
@emyoulation might be able to help you with that…

I much appreciate your help, but, unfortunately, none of your suggestions have made any difference.

  1. there is no AV software I am aware of
  2. running as admin makes no difference
  3. running the same version of Gramps on a different PC with Win 10, with the same desktop icon & link properties does not show any such ‘flashes’ and it is a ‘slower’ machine.
  4. The suggested command line string just leaves an open command prompt, after I fix the path to the executable.

FWIW & IMNSHO, Win 11 is a step back in so many ways, it has me very frustrated.
I don’t like having to click more often to get things going, my copy does not restore any open file explorer windows on start up,

For now I will have to put this down to Win 11 and be done for now.

I also had to do a complete manual removal of Gramps and reinstall for an AIO install that failed silently on my Win10… but that was a couple years ago and the memories are foggy. I seem to recall the problem appeared during an experiment with installing a couple non-english languages. The symptoms disappeared after an aggressive cleaning of bits & pieces followed by a re-install.

Have you tried using a USB flashdrive installation of the PortableApps fork of Gramps on your Win11? (And that you’ve tried and that works on Win10.) There would be no installation issues to isolate.

Hello Arnold,

I don’t see that here either, running Windows 11 on a slightly different machine, with an AMD Ryzen 7, an NVIDIA GeForce RTX 2060, 16 GB RAM, and using Bitdefender instead of the built-in AV.

When I let the setup program start Gramps, I see a console window, and two windows for Gramps, which are the main window and the database selector. And when I start Gramps normally, I just see the main window, and one short flash which looks like a console, before the database selector is opened.

Can you use a screen recorder and share the results somewhere?


Also, do you have any other GTK based applications that might be messing things up, or development tools, like a Python debugger, or Visual Studio?

Thank you all for your suggestions, but I don’t really want to go that far afield and spend all that time.
In my experience, anytime I try reinstalling one thing or another, it way too many times leads to more bit rot sets in and I end up with more trouble,

This isn’t a show stopper and I don’t want to make it one :wink:

FWIW, there is nothing else running on that PC, only 3-4 File explorer windows.
The task manager shows nothing using any CPU time

OK, I understand that, but if the cause is Windows 11, we may soon see other users with similar problems, even though the others in this thread don’t have the same experience. I say that, because I also see 1 console like window right before the family tree dialog.

And that’s still one too much.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.