Unsuccessful update from 5.1.3 to 5.1.5

Windows 10 64 bit system. Trying to update from Gramps 5.1.3 to 5.1.5

When a new to Gramps, I originally created 3 family trees. Have kept them because I’m not sure how to merge them all and I’m now quite used to it. Today, after making a backup, I tried to update from 5.1.3 to 5.1.5. Somehow I managed to lock one of the 3 family trees. I checked the user manual and opened Manage Family Trees dialogue box. Strangely none of the three family trees is listed. However, using ‘Open recent’ I have been able to open both of the other two family trees quite successfully and all seems fine.
I wondered if I had done something wrong in updating from 5.1.3 to 5.1.5 so deleted latest version and went back to 5.1.3. The result was the same, 2 family trees are fine, a message dialogue appears suggesting I force the lock for the third family tree. Again when I open the Manage Family Trees dialogue box I cannot see any of the 3 trees listed.
If you have suggestions, I would be very grateful.
Thanks very much.

Did you ever change the location of the databases? They all sit in a folder named grampsdb, which is hidden. And if you don’t change it, its location is as described here:


If you have moved it, you may have several grampsdb folders on your PC, which are easy to find with the search feature in Windows Explorer, when you set that to show hidden folders.

The MS Windows section describing the Gramps User Directory also has a link on how to turn off hiding of this (or any other) directory.

Having the Application Data folder of Windows visible can be useful in many ways.

But if you are inclined towards changing things, this is NOT a safe place to experiment. Applications tend to be very obsessive/compulsive… they expect things to be configured in a particular manner. And they often cannot deal with unexpected changes. This inability could cause it to crash or do bad things. “Bad things” could include corrupting your data or entire OS. (That is why Microsoft hides the directory by default.) Only make changes that you can reverse and even then, after you have a backup safely archived.

Right. I know what you’re saying, but when a user doesn’t see her usual trees in the Manage Family Trees dialogue box, it is quite likely that the GRAMPSDB folder was moved, and that maybe in the earlier version, she had the location of that folder changed in preferences.

I need to add that, like you, I always avoid such tricks, and that I strongly advise against using anything other than the standard settings, for the exact reasons that you mention, like a new install reverting all settings to the standard ones, and the user thinking that her trees disappeared.

I have a friend with a MacBook, which is configured by his university, and when he visits me, with that MacBook and a problem, my first action is always to start hunting for stray GRAMPSDB folders.

And indeed, your motto should always be, “Don’t mess with Texas … or … Gramps”.

Then 5.1.5 would still find it because she would still be using gramps51\gramps.ini which stores where the databases are.

My guess is that @Annette is seeing the list of her databases in the Open Recent list of trees. which is using a different file location than the location set in Preferences.

@Annette open the file recent-files-gramps.xml in your gramps user folder. This file stores the actual file location of your active databases. It will contain a path name that ends with an 8 digit alpha-numeric folder name. Other than this last folder, this tells you where the actual databases are stored.

Then in the Preferences on the Family Tree tab, there is a setting where Gramps is trying to find the databases. When you open the Manage Family Trees dialogue Gramps is looking at this path.

Change the Preferences path to agree with the path stored in recent-files-gramps.xml.

Once you can see the databases in the 5.1.3 Manage Family Trees dialogue, break the lock on that one database. Open each database in turn and make a .gramps XML backup.

Then install 5.1.5. It should also see the files in the Manage Family Trees dialogue. Once satisfied that 5.1.5 has full access to your trees, you can uninstall 5.1.3.

1 Like

Yes, that’s a good one. It reminds me of a neigbour who couldn’t find her favorites on internet, after I cleaned her PC. It turned out that she never saved any, but relied on her history, which was gone after my cleaning effort.

OTOH, in the original message @Annette wrote that she tried the Manage Family Trees dialogue, and AFAIK, that should always show all trees found in the gramsdb folder, regardless of history.

Or schouldn’t it?

The clue is that she cannot see the file that is locked using the Manage Family Trees dialogue. This is the only thing that makes sense because 5.1.3 and 5.1.5 will be using the same user folders and most importantly the same gramps.ini file.

I hope this solves it because I have no other ideas.

Thanks very much for all your help. I really appreciate it.
I have followed DaveSch advice and found recent-files-gramps but I cannot see a ‘path name that ends with an 8 digit alpha-numeric folder name’. It actually sits beneath the folders - css, env, gramps51, grampsdb, maps, temp, thumb. If I click on the XML document a pop-up box appears asking how I want to open the program. Of course I go no further because I’m too scared I’ll make things even worse.
You are right in suggesting that it is through Open Recent that I can open two of the three trees.
Any suggestions of how I can find the path name for recent-files-gramps? At the moment, when I open Preferences/Family Tree the database is set to open in a Documents folder.
You’re right I did move the database path. I was starting the backup and watched a ‘how to’ video on Youtube, following the advice on setting up preferences. I know I should have left well enough alone.
I promise never to touch Gramps pathways again (or go to Texas) but if you could make any suggestions I would be really grateful.

XML files are just formatted text files. Windows Notepad will open it as well your browser program.

If you know the path of this new location, all you need to do is set that path into the Preferences database path name on the Family Tree tab.

You can change things up in Gramps. You just need to tell Gramps where you put the files.

Thanks for your positivity.
I checked MS Windows section describing the Gramps User Directory and found that I was using the User default directory location C:\Users\Annette\AppData\Roaming\gramps - at least that’s one good thing.
I opened the xml file using notepad and this is what I found.

<?xml version="1.0" encoding="utf-8"?> 1645678327 1645671473 1645667906

Does this mean there are three locations? One for each tree? But I still can’t see the 8 digit alpha-numeric folder name.

Here is my entire recent-files-gramps.xml

<?xml version="1.0" encoding="utf-8"?>
    <Name><![CDATA[Master Family]]></Name>

So from this information my database path is:


As you can see, I also moved my database directory. The difference, my Preferences setting has this path set for my database path.

1 Like

Best news!!
I looked again at all the letters and numbers pasted on notepad (from recent-files-gramps.xml). There were three addresses. In Preferences I copied those letters that were the same in each of the three trees up to … Roaming/gramps/grampsdb. And guess what, I could see all three trees in Manage Family Trees. I broke the lock of the third tree and now I can open all three in Manage Family Trees.
I am so very grateful for all your help and patience.
I’m not sure about updating 5.1.3 to 5.1.5 now, perhaps after I’ve calmed down? Or do you think it wise if I just wait until 5.2?
Thanks again very much.


There is no time frame for when 5.2 will be ready and it might be released as a beta to fully test it. So it might be a while before it is officially released. And there is nothing to prevent 5.1.6 (or 5.1.7) from being released before then.

You can install 5.1.5 and it will not wipe out 5.1.3. You can confirm that 5.1.5 has full access to your databases and you will not need to go through what you did today before uninstalling 5.1.3.

But then again, I am an early adopter of new releases as soon as they become available.

Taken the plunge and installed 5.1.5 without any mishap. Phew!
Very happy and relieved.
Thanks again very much.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.