Cannot open database last used in 2018

GrampsAIO64 5.1.3-2 on Windows 10

It’s been 3 years since I last used my database and several changes have changed in the interim (different computer, Windows 10 re-installed; re-installation of Python, etc.) In any case, now when I run Gramps 5.1.3, I don’t see my database and there is nothing on the Open Recent menu item. I have a directory with files:
Extended Family_2018-12-12.gramps
Extended Family_backup_2018-12-10.gpkg
Extended Family_2017-04-11.ged

When I try to open the first .gramps file with grampsw.exe, nothing happens. How should I proceed?

What do I need to do to see my database in Gramps?

Thanks,
David

Did the restore fail?

Note that Gramps 5.1.4 is the current version.

The files you mentioned are backup/archival files (the .gramps & .gpkg) or old GEDCOM data exchange files.

The native database working files are different than the backups. (Databases are naturally less stable because they are updated with every touch.) Create a fresh blank Tree and import to have a working database again.

It looks like you have an archive (possibly with Media files) with the Extended Family_backup_2018-12-10.gpkg file. But the Extended Family_2018-12-12.gramps is a couple days fresher. So your best bet is to do this in 2 steps. Import the .gpkg first … just because of the Media files. (You can even delete the imported Tree. The media files will remain.) Then create another blank Tree and import the .gramps file.

It will probably find the Media files. But it might need to have the Media Verify Tool run to resolve the file paths.

2 Likes

As far as I can tell, something might be happening, with Gramps running in the background and not showing any window until the file has been fully imported. That action can be quite deceptive, so I support the advice that you just got.

Excellent! It worked and now I have recovered my database. Thank you so much for the clear instructions!

David

2 Likes