Printing a map full page

Gramps 5.1.4
With a map displayed on the screen, I select the print icon on the toolbar. It prints a map about 2 inches square on the page.
I haven’t found a option for “full page” or anything in the help. Can I print a full page?
Am I missing a step?

The screen resolution is significantly lower than print resolution. The typical screen is only 72 DPI.

You’ll want to experiment with changing the print DPI. It is probably defaulting to 300, 600 or 1200 DPI for print. So printing screen res that at 300 dpi would only show as 24% as big as the screen.

1 Like

Didn’t think of that, thanks. I’ll try that.

1 Like

Ok, sorry for my ignorance.
Where do I find the place to adjust the DPI settings?
Where can I changed the default paper from A4 to Letter?
I thought there would be something under printer or in a configuration file. Didn’t find them.

Take a look in the preferences of your printer options box:




With 600 DPI:

With 72 DPI:

Printing this:

You could play with DPI and paper size to print want you want

2 Likes

Unfortunately I don’t have that option with this printer.
image

I just did a test and printed directly to a PDF file (Microsoft Print to PDF) instead of to a printer. What was sent to the PDF was exactly what was being displayed in Gramps. So close side and bottom bars (menu >> View) and maybe send Gramps to full screen to get the most map displayed.

Once in the PDF, sending it to a paper printer may work better.

Install an electronic file print driver (like the free PDF ReDirect for Windows). It will have a lot more print control than such minimal print drivers as for your HP Officejet.

Some of these file generators support postscript output… so the image will always become optimized when it is RIPped to final hardcopy output.

The MS PDF did not work, but the PDF ReDirect did have the options and did print the image.
Thanks for all the help!!
Dave

2 Likes