Importing GEDCOM from "Family Tree 9"

People,

I just installed:

gramps-5.1.4-2.fc34.noarch (ie Fedora Linux)

My brother has produced a GEDCOM file from “Family Tree 9” - it does actually import some data by get 7504 errors reported like:

Line ignored as not understood                                      Line    18: 2 SECG Stuart
Tag recognized but not supported                                    Line    22: 2 CHAN 
Skipped subordinate line                                            Line    23: 3 DATE 2021-12-11
Skipped subordinate line                                            Line    24: 4 TIME 17:39:21

Line ignored as not understood                                      Line    25: 2 _CRE 
Skipped subordinate line                                            Line    26: 3 DATE 2021-12-11
Skipped subordinate line                                            Line    27: 4 TIME 17:39:08

In the GEDCOM file I used Vim to change all the “<0d>” bytes to LFs and tried again with the same result.

I realise there are idiosycrasies in GEDCOM files so I am not greatly surprised but being able to do a clean import would be very nice!

Thanks,
Phil.
Is there already a fix for these problems?

Do you mean Legacy Family Tree 9 https://legacyfamilytree.com/ ?

The GEDCOM errors you show are not actually errors but warnings that Gramps does not know what to do with the custom GEDCOM tag (typically start with an underscore) for example: Line 25 shows _CRE which is not a standard GEDCOM tag and Legacy’s list ( Last Updated: 2014-08-12) does not show it or how to interpret it?

Same goes for the earlier tag with no underline SECG which is not a standard GEDCOM tag and according to this article

Exported the following standard fields incorrectly:

Middle Name (Second Given Name) used tag SECG instead of GIVN (thanks to reader Peter McGregor for pointing this out).

So basically it depends on the program creating the GEDCOM to document how the custom GEDCOM should be interpreted, are you able to contact the company and ask?

1 Like

@Patsyblefebre ,

Thanks for the super-fast response!

Right.

Not really - it is a paid-for app that my brother is using on an iPad (I am a Linux person) - I just sent him a note on Telegram asking him if there is an XML export option to see if that is any more enlightening . .

I guess if I can work out what the wayward tags are for I could produce a little script to convert them to something sensible . .

1 Like

When you load the GEDCOM, in an editor that shows line numbers, you can see the context, and I bet that the _CRE refers to the creation time of an object. And I say that, because it appears to be in the same context as the CHAN line, which gives the time of the last change, but seems to appear in a non standard place.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.