Gramps not opening Gramps or GED files

Hi. I’ve backed up, and also tried exporting, files in .gramps and .ged formats. When I try to open either I get a message:
The document “xxxx.gramps” could not be opened. Gramps cannot open files of this type.


The document “xxxx.ged” could not be opened. Gramps cannot open files of this type.

I’m on version 5.1.3 on MacOs Catalina 10.15.7

I can’t think what I am doing wrong. Would love some help. Thanks… Peter

Are you sure it is a GEDCOM; what program created the GEDCOM file, you should be able to check by opening it in a text editor and looking at the first few lines? eg:


2 NAME Personal Ancestral File
2 VERS 5.0
1 DATE 30 NOV 2000
2 VERS 5.5

In Gramps did you create a new family tree before importing it?

Both files were created by me, from Gramps. When I open Gramps it offers me one choice of family tree to load which it calls Family Tree 1. I load that, do a Backup, and select a name eg Humphry with the default extension of .gramps. It saves. (Equally, I do an Export, select GEDCOM as format, choose humphry as the name and accept .ged as the extension. It saves)
If I then go to the folder in which they are saved, and click on either, I get the error message(s) as described.
I’m flummoxed!

Does creating a new empty family and importing either of the files work for you?

Ok in MacOS you are just clicking on the files; as I’m not a MacOS user I can’t say what should be happening, something not configured correctly or an issue with you Gramps install?


Neither a GEDCOM.ged or a GRAMPS.gramps file will open in Gramps. To open them you would need to create a new database/tree and then Import either file into the new tree.

The files you created are for either backing up, saving/protecting the work you created, or creating a file for someone else to use and import into their database. The .gramps file is a compressed XML and should always be used when the program importing it is also Gramps. The other formats are available when another program cannot import the xml file. The media package file .gpkg can include the media files for the export/backup.

In the Family Tree Manager window you can rename the database “Family Tree 1” to “Humphrey” if you want.

In Preferences (menu Edit >> Preferences) on the Family Tree tab you can check the box Automatically load last family tree : and another helpful check box on the General tab Remember last view displayed :

Thanks to everyone who replied, I’m excited to have received such prompt and helpful replies. I’m new to Gramps and am having a few problems so think I’ll find myself reverting to this forum again. Importing the files into a new database, rather than “clicking” on them, worked beautifully.
I should probably start a new thread but while I’m with such knowledgeable people, can anyone tell me how to add a second surname eg when someone gets married the maiden name is useful to keep for tracing but the “new” married name becomes the preferred. I can’t figure it out. Thanks again…

In a person’s edit window, there is the Names tab. You can add additional names here as needed using the Name Editor. There are also additional settings you can apply to the Preferred Name. To move a name into the Preferred slot use drag-n-drop.

FYI: There is the name Type drop-down. If there is not an option that suits your needs, you can just type in a custom option. This works on all drop-down lists. The one major caveat, any custom entry will not translate if that is a functionality you will need.

Thanks once more, DaveSch you are a wiz. (And if you’re wondering, that’s a good thing!)

@PeterH, just checking, did you use a “.dmg” file to install Gramps or did you build from source?

I used a .dmg I think, just a regular Mac download of the application.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.