Found a gramplet named prerequisites, some missing

PangoCairo 1.0 not installed, don’t have it in my repo. Running KDE and Gramps 5.1.2. Is this required for KDE? xdg-utils and language pack for gnome missing. can’t find python-fontconfig. Can’t find PILLOW 6.2.2 nor ttf-freefont nor rcs.

In the tutorial, the “Bottombar” has a Garner Von Zielinski. I don’t have any such gramplet. how do I get a gramplet that shows person stuff?

What Linux distribution are you using?

Maybe also paste the contents of your Prerequisites Gramplet results.

In the tutorial, the “Bottombar” has a Garner Von Zielinski. I don’t have any such gramplet. how do I get a gramplet that shows person stuff?

A link to the tutorial page or image you mean would help?

It would be helpful if we saw the output of the Prerequisites checker.
Regarding PangoCairo; if Gramps is running well enough to show the checker, then this is installed. I suspect that the library may have changed the way versions are reported so the checker cannot find the version info. Which may be a bug.

xdg-utils is almost certainly present, it is used to open files by looking at a file extension.
I would not worry about language pack, if your OS has the languages you need installed, Gramps can use them.

ttf-freefont is only needed if you are unsatisfied with what your reports look like; most likely the OS has enough standard fonts installed that adding extras are not necessary.

rcs is only needed if you want to use this versioning system with the Gramps files; I’ve never used it myself, it seems a bit esoteric for most normal users.

PILLOW is installed if you are getting 6.2.2 as the version number, otherwise it would say ‘Not found’.

The ‘Bottombar’ if shown (see menu “View/Bottombar”) comes with a set of default Gramplets that should show details of the selected person (or other type of object in other views). The ‘Details’ tab (Gramplet) is probably the one you are looking for. The ‘down pointer’ at the far right of the tab names can be used to install/remove/restore defaults if you have changed something.

I’m running KDE, pclos kernel 5.6.19
I can’t find the “Details” gramplet. I got up this a.m. and looking at the Gramps, I notice there is no tree loaded. It was there when I walked away last night. And I still get this other error when attempting updates. See screenshot:

And then to answer the prereqs screen here is another screenshot:

It’s a built-in feature & enabled by default. But since much of the interface makes no sense (or might not be visible) without data to show, import the example.gramps tree.

You’re talking about a ‘fully loaded’ example of interface in the visual guide to the Gramps main window interface … which has LOTS of options enabled so that they could be labeled. (The idea of the Visual Guide being that, if you don’t know the name of parts of the Gramps interface, you could spend half your life trying describe what you see enough for people to start answering your questions! You have to have a vocabulary in common to ask answerable questions.)

In that case of Fritz’s question, the Bottombar was enabled (via View => Bottombar) in the People View. This had added tabs for the following built-in Person gramplets: Details, Gallery, Events, Children, Citations, (the following scrolled off-screen) Notes, Attributes, References. It also had the Sidebar on right the Filter Gramplet. This is how the Grouped mode of the People view was configured by default.

With L.A.Garnet von Zieliński, Sr. selected, Details Gramplet tab in the People view should show his detail.

Regarding the installation errors; it looks like you have tried to install every addon.
The PostgreSQL addon provides an alternate back end database, usually only used by experts trying to do something rather unusual. And you don’t have its prerequisites installed (you don’t need them for normal use).

The Graphview and Network chart both have the common requirement for Graphviz. So that is probably not installed. I couldn’t tell for sure, because you posted a picture of the Prerequisites checker showing only the first part of the output, rather than pasting in the whole output.

There is no example.gramps file on my computer and the example.gramps file link takes me to a file that won’t download. It will open instead. Not importable if I can’t get it to my computer is it?

I could not get it to expand, only scroll. the portion that was marked as must have was fully visible in the screenshot. the other portions were marked as optional. So from your descriptions it sounds like I have everything but the example installed and I must figure it out.

If a browser opens a file when clicking a link, there is ALWAYS an option to save/download instead. Try right-clicking the link to show the contextual menu instead of left-clicking (which accepts their default action)

And, except for Mac downloads, the Gramps installs should all include the example.gramps file. Please look again.

You seem to be having problems with operations most Linux users understand intimately. What is your computer skills background?

Wow that was difficult to find, pclos is an abbreviation for PCLinuxOS, with all the issues you are having my guess is that your installation for both PCLinuxOS and Gramps was not done correctly. Also according to this review PCLinuxOS KDE 2020.05 Review: Not for the Novice you may want to try a easier Linux distribution like Ubuntu 20.04?

How did you install Gramps did you use the rpm file from PCLinuxOS or the deb file from the Gramps project download page?

Can you start a open a console or terminal and type the command:

gramps

this should start Gramps and if you can copy paste the output from the command line here (not a screenshot!) it should help us confirm if Gramps is installed correctly?

I’ve been using Linux since 1994, I’m just not a power-user. Before that I used to use Minux because I fixed machines that used that in Tekware controllers. And I’m an old Solaris and BSD user before there was a win95. But PCLOS has been my mainstay for about 10 years. Gramps came on this install with the distro, this is Magnum PCLOS. Gramps is installed from the get-go. I just can’t remember all the commands so I stick with the GUI as much as possible.


And here is a screenshot of the Gramps folder, no example.gramps

this is what I get when I use the “Download” button in “Github”


A download does not happen, a file opens instead
It’s very possible I have a bad install, this is the third install of “Magnum” because I’ve screwed something up, but I’m not seeing anything different with this running of Gramps than I’ve had with the previous attempts. I’ve never seen the example operate.
I don’t like to use Ubuntu because it uses sudo. I use Ubuntu to run the movies on my TV, not for anything the requires security.

Fortunately, the example.gramps is a plain text file with XML structure. Worst case, you can copy the contents to a new, blank text file (no automatic line wrapping!) and rename it “example.gramps”

That should import with no problem. If you DO have a problem, I will eMail it.

The first line starts with:
<?xml version="1.0" encoding="UTF-8"?>

and the last lines (#66067 & a blank line on 66068) with:
</database>

I’ve been attempting a “Copy Paste” to no avail to Kate and Kwrite (editors that don’t insert stuff). something is inhibiting this process. I am stumped at the moment.
Can you email it? fritzvisio@linuxmail.org I’m going to have to get with the support forum and see if they know anything. something else is going on.

Hi, Sorry to read your having a-lot of issues!

Your console image above shows the following line

Gtk-Message: 17:31:56.449: Failed to load module “appmenu-gtk-module”

94426a6111a5dadc041b0099763c960f3c715482

A quick search on the PCLinuxOS forum brings up the following result

Which ends up asking the person to install the required file ( appmenu-gtk-module-0.7.1-1pclos2019.x86_64.rpm ) to enable the global GTK menu’s for the program they had an issue with.

You may have to open a request with the PCLinuxOS forum or bug tracker to get the right version of the file for your installation.

Ok thanks. went to the repo and installed the appmenu. I still have the warning about graphview.

[jan@Alpha-Site3 ~]$ gramps
2020-07-21 19:31:46.152: WARNING: graphview.gpr.py: line 50: Graphview Warning: Goocanvas 2 (https://wiki.gnome.org/action/show/Projects/GooCanvas) is required for this view to work.
I don’t know what to do to fix that as goocanvas2 is installed

I was doing it wrong. I thought I was downloading a file. Right-clicking on the Download gave me a choice to save the file as a link and then I was able to get it to import into gramps. I can’t ever remember saving a link to my downloads folder using a download button to get a download to function.
Thanks for the help

1 Like