Problem with Graphview after OS reinstall

I reinstalled Kubuntu 22.04 but managed to keep my home partition. I then installed gramps 5.1.6 and it picked up all my data correctly (Wow!)

but Graphview doesn’t work. I notice that it is in the .gramps/gramps51/plugins folder as mentioned in the wiki, but how can I get gramps to find it?

I do have another thing about Place coordinate gramplet not being there, but one thing at a time.

Using the preferences to check for updated plugins doesn’t do anything - no plugins to update.

How do I proceed?
Peter M.

Try installing the Prerequisites Checker addon gramplet.

I expect that you will see some prerequisites that are missing and need to be re-installed.

Thanks. It took me a while to find the Plug-in manager under Help, and then to discover that the preRequisites Checker was already there. But that helped me to discover that I needed to install Graphviz and also goo canvas, and I also installed a geography thing whose name I forgot to write down, But everything is now working.

Thanks for guidance.


Should the Prerequisites Checker be part of a base Gramps install? I know it is rather geeky to many users but it is pretty valuable when stuff doesn’t work as expected.


It is easier to distribute updated versions via the the addon system.

Evolution of built-in features is glacially slow.

1 Like

Yikes, I hadn’t realized that it was implemented in such a ‘brute force’ manner.

Over 2,000 lines of code with some tests conditional on the user’s OS, etc. My sympathies to those maintaining it. :wink:


I strongly suggest no for exactly the same reason :stuck_out_tongue:

Created by myself to help triage the bug reports.

Yeah, only way I could do it, not being a programmer myself :joy: a lot of trial and error went into it.


Why ?
You don’t need this plugin. You can use “gramps -v” in a terminal.
You’ll have the same result. For a bug report, we ask for the result of “gramps -v”.

1 Like

Not really. Here is the output of gramps -v on my Mac:

$ gramps -v
Gramps Settings:
 python    : 3.10.13
 gramps    : 5.1.6
 gtk++     : 3.24.38
 pygobject : 3.46.0
 pango     : 1.50.7
 cairo     : 1.17.6
 pycairo   : 1.23.0
 osmgpsmap : 1.0
 GExiv2    : 0.10
 ICU       : 73.1
 PyICU     : 2.8
 o.s.      : darwin
 kernel    : 19.6.0

Environment settings:
 LANG      : en_GB.UTF-8
 GRAMPSI18N: not set
 GRAMPSHOME: not set
 GRAMPSDIR : not set

Non-python dependencies:
 Graphviz  : 8.1.
 Ghostscr. : 10.02.0

System PATH env variable:

 bsddb     :
     version     : 6.2.9
     db version  : 6.2.32
     location    : /opt/local/Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages/bsddb3/
 sqlite3   :
     version     : 3.43.1
     py version  : 2.6.0
     location    : /opt/local/Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/sqlite3/


And here is the output of Prerequisite Checker on the same system:

Diagnostic Gramplet to help evaluate if Gramps has all prerequisites installed.

You have Gramps 5.1.6. Congratulations, you have the current version.

The following packages MUST be installed (Requires the minimum version or greater.):
* Python 3.10.13 (Passed: version 3.3.0 or greater installed.)
* GTK+ 3.24.38 (Passed: version 3.12.0 or greater installed.)
* PyGObject 3.46.0 (Passed: version 3.12.0 or greater installed.)
* Cairo 1.17.6 (Passed: version 1.13.1 or greater installed.)
* Pycairo 1.23.0 (Passed: version 1.13.3 or greater installed.)
* Pango 1.50.7 (Passed: version 1.29.3 or greater installed.)
* PangoCairo 1.0
* Berkeley Database library (bsddb3: 6.2.32) (Python-bsddb3 : 6.2.9)
* SQLite Database library (sqlite3: 3.43.1) (Python-sqlite3: 2.6.0)
* xdg-utils (Manual check see instructions link)
* librsvg2 (Manual check see instructions link)
* language-pack-gnome-xx (Manual check see instructions link) for your Language <show locale here TBD>

The following packages are STRONGLY RECOMMENDED to be installed (needed for geography and charts):
* osmgpsmap 1.0 (Passed: version 1.0 or greater installed.)
* Graphviz 8.1.
* PyICU 2.8(ICU 73.1)
* Ghostscript 10.02.0
* python-fontconfig not found, (Requires version 0.5.x)

The following packages are optional:
Gtkspell enables spell checking in the notes.
* GtkSpell 3.0 (Passed: version 3.0 or greater installed.) (enchant module: not found)
* rcs installed TBD (Requires version 5.9.4 or greater installed. If not on Microsoft Windows)
Python Image Library (PIL) is needed for cropping images and LaTeX output.
* (PILLOW 9.5.0)
* GExiv2 : 0.10 (Exiv2 library : 0.27)
* geocodeglib 1.0 (Passed: version 1.0 or greater installed.)
For addon Networkchart, font White Rabbit provides an extremely readable result.
* Installed font: found another font

Development & Translation Requirements
The following packages should be installed if you intend to translate or do any development (addons etc):
* gettext (msgfmt): 0.21.1
* intltool-update: 0.51.0
Sphinx is a tool that builds the Gramps development documentation and man pages
* Sphinx: not found

Optional packages required by Third-party Addons
Prerequistes required for the following Third-party Addons to work:
01. Addon:Family Sheet : (PILLOW 9.5.0)
02. Addon:Graph View : (GooCanvas:2.0)(PyGoocanvas: TBD?)(Graphviz 8.1.)
03. Addon:PedigreeChart : (NumPy : 1.25.2 )
04. Addon:Network Chart : (networkx 3.1)(Graphviz 8.1.)
  and one of either: (pydotplus: not installed) or (pygraphviz: 1.9)
05. Addon:GenealogyTree : (lualatex :not found)(PILLOW 9.5.0)
06. Addon:HTMLView : (Webkit: not installed )
07. Addon:GoogleMapKML : (Google Earth on Desktop : not found.)
08. Addon:Webconnect Pack : (libwebconnect : Installed)(Passed)
09. Addon:TMG Importer :  (DBF not found.)(Requires version 0.96.8 or greater installed.)
10. Addon:PostgreSQL Database library Support : (PostgreSQL not found.)(psycopg2 : not found.)
11. Addon:Edit Image Exif Metadata : (PILLOW 9.5.0) GExiv2 : 0.10 (Exiv2 library : 0.27)
12. Addon:Photo Tagging Gramplet : (NumPy: 1.25.2)(OpenCV facedetection: 4.8.0)
13. Addon:Lxml Gramplet :  (lxml: 2.11.5)(libxslt: 1.1.38)
14. Addon:MongoDB : * Requires: MongoDB TBD / pymongo TBD

Diagnostic checks
Check for potential issues.

Environment settings:
* Operating System: darwin
 kernel: 19.6.0

Locale Settings:
* LANG:  en_GB.UTF-8
* LC_MESSAGES:  not set
* LC_TIME:  not set

Gramps Environment variables:
* GRAMPSI18N:  not set
* GRAMPSHOME:  not set
* GRAMPSDIR:  not set
* GRAMPS_RESOURCES:  /opt/local/Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages

Locales available:

Installed Locales\Translations (If only English is listed please re-install Gramps again and make sure to select all the Translations and Dictionaries)

sq : Albanian
ar : Arabic
bg : Bulgarian
ca : Catalan
zh_HK : Chinese (Hong Kong)
zh_CN : Chinese (Simplified)
zh_TW : Chinese (Traditional)
hr : Croatian
cs : Czech
da : Danish
nl : Dutch
en_GB : English
en : English (USA)
eo : Esperanto
fi : Finnish
fr : French
de : German
el : Greek
he : Hebrew
hu : Hungarian
is : Icelandic
it : Italian
ja : Japanese
lt : Lithuanian
nb : Norwegian Bokmal
nn : Norwegian Nynorsk
pl : Polish
pt_BR : Portuguese (Brazil)
pt_PT : Portuguese (Portugal)
ru : Russian
sr : Serbian
sk : Slovak
sl : Slovenian
es : Spanish
sv : Swedish
ta : Tamil
tr : Turkish
uk : Ukrainian
vi : Vietnamese

Back Up Your Genealogy Files.
Time to back up your genealogy files, and then test your backups!
Backup to Gramps XML You will find backup in the Family Tree menu of recent Gramps versions, otherwise use Export in the same menu but uncheck privacy options in the Exporter Assistant in order to export all data.
* Backups can be made at any time and at least on the first day of every month, if not more often.
* Before any upgrade it is strongly recommended to backup each of your Family Trees.
* Test your backups by creating a new Family Tree and importing the backup.


There are numerous differences in detail but the main thing that Prerequisites checker adds is looking for dependencies needed by common addons. Eg Pillow, Goocanvas, NumPy, etc.

(I wish there was a way to run PreReqCh to ONLY list missing deps.)

This is for gramps 5.1.6.
You have the same things with a different order.

This has been updated for 5.2

We only need “gramps -v” to know the version of the installed modules.
With gramps -v, we have more infos needed for debugging: environment, paths

‘gramps -v’ calls ShowSettings():

If the results of that function where made accessible to Prerequisites Checker, quite a bit of duplicated effort in the addon could be eliminated.

Then the Prerequisites Checker could focus on only dependencies needed by the addons?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.