Top bars are missing

Where it says “File” and the last topic “Help” that whole bar is missing. the next one that has “Family Trees” is missing too. I tried a re-install but both lines are still missing. Is this an install issue? Or a setting?

I tried removing and re-installing. Still same problem, top two bars is either off-screen or not there. the Gramps window consumes the whole screen, can’t re-size it.

Are you in Full screen mode or is Gramps just larger than the display?

Did you press “F11” to Maximise Gramps to use the Full screen ? if so press it once more to return to normal.

Or if your Gramps has been resized larger than your display you need to resize

Well that did bring in a line across the top that says which tree I’m looking at and the three dots in the upper right corner. so I guess I need to read about the resize. Thanks!

You should be able to invoke off-screen menus using OS hotkeys

Use the hotkey for the Edit menu and select preferences.

Try deselecting the Remember last view displayed in General preferences.

You can use the keybindings to choose OK and quit Gramps (Ctrl-q or cmd-q).

See if Windows auto re-sizes to screen when you re-open Gramps.

If not, see this thread in the maillist archive. The alt-F7 suggestion (for dragging the Window until you can grab the re-sizing window widgets) & editing info (for stored window dimensions in the gramps.ini) should be helpful.

Thanks! The F11 key got me a I think, a titlebar. It has a Gramps icon at far left, next to it a round dot, in the middle the title of the family tree and a changable section that changes with which menu in the left panel has been selected and then the word Gramps. To the far right I get the 3 dots that minimize expand/shrink and quit dots. BTW I’m running KDE.
The appearance of this new bar has allowed me to grab the screen and pull it away from the top edge of the display, so now I can see the whole Gramps screen in the middle of the display monitor.
The hotkey for Edit is not working. Alt+E. The menu bar is still missing. I can’t find a way to get at preferences as the “tabs” are missing.
When I tried to re-install after complete removal(used synaptic), the Gramps fired right up and loaded the tree I was working on before. That was un-expected as I had performed a complete removal and was expecting to have to reload everything. Also, the permissions in the launcher has the owner as Root. Shouldn’t the owner be the user?

It might help a bit if you tell us about your OS and version. You did mention KDE. What version of Gramps are you using?

Recent versions of Gramps don’t have a ‘File’ menu item at all. The normal menu bar starts with ‘Family Trees’ and ends with ‘Help’. Is this what is missing?

I use KDE and the gramps from the repo, version 5.1.2. Yes the menubar: “Family Tree” “Edit” “View” “Help”, is missing. (Sorry, so used to seeing “File” I thought I was looking for that.)
The tutorial talks about using a Select inside a box (indicates a select button) I can’t find. So if the menu bar is supposed to be missing, and other features are missing, then the posted tutorial is incorrect. The “Help” ? How do I get help from the application? So is this a bad release?

It seems like there have been several maillist grumblings about Windows appearing off-screen. They have mostly seemed to have been related to a recent user change of the screen (or font) configuration.

Do you know if Gramps validates to see if the screen configuration has changed?


I just shut it down and restart puts the window back where it was, close to exactly the way it was. The menubar is still not there. I have no idea how to find the validator as the menubar is not there.

Sorry Fritz. I replied to Paul’s posting but should have addressed the text to him as well. I wasn’t expecting you to answer that technical question.

I did find a general posting on another message board about a KDE option to hide & reveal an application’s menu bar. It had a solution with a couple alternatives that you might want to try.

It appears to be this one application and control+m shows/removes the left-most panel. Yes the example you found is what I have er don’t have. It’s missing. the solution doesn’t resolve

The uppermost left corner gives me a mini-gramps icon that allows window properties management. Is this where i need to be looking for a solution?

And I just discovered my Dolphin screen resembles the example, the menubar is missing too

That Gramps icon sounds like the toolbar than that missing menubar.

The following is from the visual guide to the Gramps interface:

Dark mode comes up for me but the screen you show is almost the same. The menubar for me is missing

This sounds similar to a problem I had, it turned out that my Gramps file was corrupt after moving across from a Mac to a Windows PC. I seem to remember that I deleted the file in the database manager (Family Trees/Manage Family Trees…) and started a new tree into which I imported the Gramps file, or possibly a backup copy.

1 Like

I tried using synaptic to remove, but re-install did not walk me through installing anything. It just started working like it was before the moment I hit launch.
Also, the launcher properties are Root permissions. Is that what it should be?

If the file manager (that’s the ‘Dolphin’ you mentioned, right?) is missing the menus too, then the solution will not be within Gramps. You must’ve changed an OS setting.

Go back to that KDE posting mentioned above & few replies earlier. Don’t stop with the first alternative mentioned (the alt-m hotkey) … it didn’t help that poster either. There were a couple more options including a global.

They developers also noted that they eventually patched the application too. (With a link to the patch documention.) But the workarounds seemed to be effective albeit a bit harder to find.

I am not using the same OS and guessing on unfamiliar ground.

1 Like

Thanks, I’ll look elsewhere.

I’ve got it using the 3 bars, has a dropdown menu. Now I can start learning how to use it. Thanks for the help!

1 Like

Hi, sorry, I forgot my password. And I forgot the solution to the problem. It was not a setting in Gramps and I still don’t have the menu bar back. At the far upper left corner I now have the Gramps icon with 3 horzontal bars. When I click on that, I get a drop-down menu of the missing menubar. To get this it was in the KDE control center or system settings. There were several applications not just Gramps that had missing menubars. Never found the cause of the problem. And don’t have the time to learn this new to me Gramps. I am impoverished for time at the moment. FYI-using distribution 5.6.19-pclos1 and Gramps is 5.1.2.