Export GED doesn't include everyone in my tree

I’ve merged two gramps files. The final product contains approx 1600 people. When I try to export to a GED file it only include 600+ people. How am I able to include the entire data base of people in the file?
Thanks for your kind consideration and help.

1 Like

When you created the GEDCOM did you have any filters or privacy settings enabled?

When you press the “Calculate Previews” button does the calculated output of the filters match what you expect?

Read about the settings:
https://www.gramps-project.org/wiki/index.php/Gramps_5.1_Wiki_Manual_-_Manage_Family_Trees#Export_options

@sam888 Thank you for your response. I did not have any filters enabled. No, the Calculate previews did not match my expectations. Yet when I look at the “people” dialog window it includes everyone that is in the merged files.

Could you expand on how your expectations were not matched?

1 Like

Do you get the same problem when exporting to Gramps XML?

1 Like

@Nick-Hall @sam888 @emyoulation I have two ged files from two different trees. One file has 1230 entries. The other has 628 entries. Both of these files were exported from the myheritage site. There is only a fragment of cross over identities. I attempted to merge these files in two different ways.
First I opened my main family tree based on the smaller ged file. I then imported the larger ged file to merge the trees. They seemed to merge.
I also tried creating two trees in gramps. One from each ged file. Then I exported in gramps xml for each tree.
I created a new tree containing the smaller file and imported the other in order to merge the trees. Both attempts seemed to merge. Nevertheless when I export the “merged” tree the ged has only 600+ recognized individuals in the final document.
I’m obviously fouling the works up somewhere.
At this juncture I have exported two csv files. One from each unique tree. I am hoping to do a comparison to see how many individuals can be merged. It will be slow process but at least I should have a fair estimate of what the diff should be.
Any ideas on any of this are most welcome.

I believe we understand the nature of the desired outcome. But some of your problem description lacks (or summarizes over) critical information.

First, by ‘records’, do you mean 628 & 1230 Persons? (Each source, events, place is also described as a record.)

The “seemed to merge” is unclear… partly because “merge” may mean something different to us. It means the reduction of duplicate records by combining 2 matching records into 1. But from your description, this probably is NOT what you mean? Do you mean joined? As in, you imported a GEDCOM of 628 Persons… then imported the second GEDCOM of 1,230 Persons with the resulting (“joined” rather than “merged”) Tree having 1,858 Persons?

(You can check those kinds of Statistic at any time with the Reports => Text Reports => Database Summary Report)

Finally, the Preview of the export would tell us a lot… but “Calculate previews did not match my expectations” lacks vital detail. What is the number of People for it’s “unfiltered family Tree:”? (Is it over 1,800 people?) We anticipate from your disappointment that the Preview also showed “600+” somewhere… but your description doesn’t tell us which rows report that or which filter rule is on each row.

We’re stumbling in the dark without this enlightening information.

You could help us by capturing the disappointing Export Preview & pasting it in your reply. And pasting the results of one of those “Database Summary Report” on the joined Tree would eliminate a lot of guessing too.

1 Like

@emyoulation Very helpful! The db summary report clearly says 628 individuals. Obviously the ged file I sought to import is not being recognized. I am going to go back and start from square “a” to see where I misstepped. I will get back to this thread with the results of the new outcome. Thanks again. @sam888 @Nick-Hall

2 Likes

@sam888 @emyoulation @Nick-Hall Progress. Here’s my analysis so far. I was attempting to use the import and merge tool. Doesn’t seem to work with .gramps files derived from two separate .ged files if the two files are not forks of the same project.
Instead I used the import option directly Family Trees > Import and was able to merge the two family tree .gramps files. I have duplicates to deal with now but that’s a far cry from where I was at earlier this morning. :wink: Current db includes 1844 individuals. I’m very pleased. Simple task now to deal with duplicates and sort out convention differences of the two trees.
I appreciate your patience and help as I climb this learning curve. Hopefully by hanging around here I will absorb semantics by osmosis and be better at communication.
My sincere gratitude for your attention and time.

3 Likes

That is good news.

The Import and Merge tool is a third-party addon. We assumed that you were using the standard Gramps import as you are now.

2 Likes

I was happy to read you found the issue.

I’ve never needed to use the “import merge tool” add-on. It gives no alert if the files are a mismatch? … it just silently aborts? That sounds like you discovered an interesting place it could be enhanced.

You might find it would give you a leg up on the terminology to look through the Visual Guide to the GUI and maybe the Glossary. We’re trying to make it useful for just that purpose and would appreciate some feedback.

I spent a day of my life whittling down my duplicates. We’re at a solid 1623 individuals going back as far as the early 1700’s of Eastern Europe.
Thanks for the leads regarding terminology. Very interested in that and will certainly give it a look. Glad to contribute if I can.
A GUI utility to edit large scale changes in the database as far as documentation conventions are concerned would be very helpful also. I.E. select a key word in a particular column/data category such as event places and be able to sort and edit. Very much like the duplicates sort function.
Thanks again for pointing me in the right direction.

Ha! Took me a minute after the above reply to find the utility. Works great. You can nix my utility request. :slight_smile: