CSV Export not responding/freezes

Hi all. Using the latest Gramps on Windows 10. I am attempting to export my places in csv format using FamilyTrees menu >export, choosing csv format and unchecking all boxes except places and translate headers. It freezes within about 5 seconds of clicking apply, (not responding), never recovering and I have to close it through task manager. I closed all other programs first and it didn’t help. I also tried leaving the all the boxes checked, ie the whole database of 17,000 people, and of course, that froze also. The most recent things I’ve done:

Restored a backup because things seemed messed up and I’d gotten an error, which I don’t recall now.

Imported a small .gramps place file shared with me then merged a couple of the duplicates. It crashed during the merge process too but then it was successful after restarting.

Any ideas?

I just tested. I am running 5.1.2 on Win 10 with 24,595 place records.

I unchecked every option except Places. After clicking Apply, the export did hang for a while “Not Responding” but leaving it be, liting it sit, it did resolve itself and made the export.

I did an import of the results and everything was fine.

I had waited 30’ with the same result. I just tried again for at least that long. It must be something gone wrong with my pc or gramps installation?

I tried the database used before I brought in the backup and it works fine so it must be a problem with my back up or the small places file I merged into it.

Mine was a wait, but not 30 minutes.

Until today, I had never made a CSV export. CSV are built in functions (not addons) so you have the most up-to-date version and I did not see an open bug dealing with CSV exports.(although others seem to be able to find bugs I seem to miss).

Other than doing a Check and Repair to see if there are any issues, do not know what else to suggest. Hopefully someone else may have other ideas.

Importing data from another source is always a good way to introduce weirdness.

After backing up & running the basic repair tools & utilities. I’d backup again, then create blank Tree to import the backup which rebuilds it from scratch. (Turn off the import Tagging Preference on a blank Tree import. Without other records to be differentiated, Tagging just slows down the import.)

This is a good periodic step to compact the data & clean out unused data. It is also a good time to change ID preferences if you didn’t have enough leading zeroes for the number of records.

Note that the change in ID will may cause compatibility difficulties with tools like the Import merge Tool or URLs you may have shared from web reports.

The small file I imported was a gramps file that contained only London enclosures. So that I wouldn’t have duplicate IDs I had changed the formatting for Place IDs in preferences to 05 and maybe that was creating the problem. This time I created a new tree with my database backup and reordered the London file place IDs so that they started with PL instead of just P. I think that must have been better than changing the leading zeros because I imported the new London gramps file, exported the csv and it worked. So, reordering IDs is better than changing the format in preferences, if we are going to merge. Thanks for the support and suggestions.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.