Can not open GPKG

Using Linux Mint (5.1.3)

I have a problem with opening my GPKG
I dont know what to do …
Who can help me?

21725: WARNING: line 1419: database is closed
49434: WARNING: line 1419: database is closed
54444: WARNING: line 390: If upgrade and loading the Family Tree works, you can delete the zip file at /home/eeepc/.gramps/
83904: ERROR: line 156: Unhandled exception
Traceback (most recent call last):
File “/app/lib/python3.8/site-packages/gramps/gui/”, line 942, in import_data
File “/app/lib/python3.8/site-packages/gramps/gui/”, line 131, in import_file
GrampsImportFileDialog(self.dbstate, self.uistate,
File “/app/lib/python3.8/site-packages/gramps/gui/”, line 473, in init
if self.check_errors(filename):
File “/app/lib/python3.8/site-packages/gramps/gui/”, line 535, in check_errors
f = file(filename,‘w’)
NameError: name ‘file’ is not defined

536443: ERROR: line 570: Failed to import database.
Traceback (most recent call last):
File “/app/lib/python3.8/site-packages/gramps/plugins/lib/”, line 2753, in parse_gedcom_file
File “/app/lib/python3.8/site-packages/gramps/plugins/lib/”, line 3556, in __parse_record
File “/app/lib/python3.8/site-packages/gramps/plugins/lib/”, line 3655, in __parse_indi
self.__parse_level(state, self.indi_parse_tbl, self.__person_event)
File “/app/lib/python3.8/site-packages/gramps/plugins/lib/”, line 3609, in __parse_level
func(line, state)
File “/app/lib/python3.8/site-packages/gramps/plugins/lib/”, line 4011, in __person_birt
event_ref = self.__build_event_pair(state, EventType.BIRTH,
File “/app/lib/python3.8/site-packages/gramps/plugins/lib/”, line 7907, in __build_event_pair
self.dbase.commit_event(event, self.trans)
File “/app/lib/python3.8/site-packages/gramps/plugins/db/bsddb/”, line 1872, in commit_event
self._commit_base(event, self.event_map, EVENT_KEY,
File “/app/lib/python3.8/site-packages/gramps/plugins/db/bsddb/”, line 1725, in _commit_base
self._update_reference_map(obj, transaction, self.txn)
File “/app/lib/python3.8/site-packages/gramps/plugins/db/bsddb/”, line 1099, in _update_reference_map
primary_cur = self.get_reference_map_primary_cursor()
File “/app/lib/python3.8/site-packages/gramps/plugins/db/bsddb/”, line 254, in try

return func(self, *args, **kwargs)
File “/app/lib/python3.8/site-packages/gramps/plugins/db/bsddb/”, line 317, in _get_reference_map_primary_cursor
return DbBsddbAssocCursor(self.reference_map_primary_map,
File “/app/lib/python3.8/site-packages/gramps/plugins/db/bsddb/”, line 193, in init
self.cursor = source.cursor(txn)
AttributeError: ‘NoneType’ object has no attribute ‘cursor’

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/app/lib/python3.8/site-packages/gramps/gui/”, line 556, in do_import
self.import_info = importer(self.dbstate.db, filename,
File “/app/lib/python3.8/site-packages/gramps/plugins/importer/”, line 139, in importData
File “/app/lib/python3.8/site-packages/gramps/plugins/lib/”, line 2765, in parse_gedcom_file
File “/app/lib/python3.8/site-packages/gramps/gen/db/”, line 77, in exit
File “/app/lib/python3.8/site-packages/gramps/plugins/db/bsddb/”, line 2110, in transaction_abort
File “/app/lib/python3.8/site-packages/gramps/plugins/db/bsddb/”, line 2117, in __after_commit
AttributeError: ‘NoneType’ object has no attribute ‘txn_checkpoint’

Judging by the error report, you tried to open a file that did not exist. This doesn’t happen very often so you found a bug that has been around for quite a while. We need to fix this. However, I cannot figure out how you managed to do that with the GUI; it doesn’t normally allow you to select a non-existent file.

Then it looks like you tried to import a gedcom file, possibly into the same db, and without getting Gramps restarted. I suspect that the prior error left Gramps in an unstable state. Causing the other errors.

I suggest that you close and restart Gramps, use the Family Tree manager to delete the db you were messing with, or at least make a new db, and then use the GUI to try the gpkg import again.

1 Like

My base was a gedcom-file, but I worked in it since months. Every time I worked in it I thought I made a back-up on a USB stick. Now I see the back-ups are empty…
So I think all my work was for nothing…

What to do not getting that again or what to do to get a good working gramps program?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.