Importing Family Tree File Issue

Gramps version 5.1.3 and Operating System Windows 10
Unable to install a downloaded file (.gpkg ) family tree into Gramps. Gramps can NOT find downloaded file.gpkg when launched. I no longer see an “IMPORT” command when launching Gramps. At one time I did and it gave me Extraction Error when I tried|thee “import” command.
Any suggestions ?

You have to create blank Family Tree to receive the import data before the Import menu item appears.

(Family Trees are in a database format for active editing and browsing. The .gpkg file are archives… in a data exchange XML format. XML formats are robust & highly portable but too bulky for live database access.)

Follow the same process as importing the Example.gramps sample Tree. Just find & select your .gpkg file instead of the example.gramps file.

(Note that you can paste in the filepath if you change the File Selection dialog’s navigation from ‘breadcrumbs’ browsing mode with the Crtl-L shortcut keybinding.)

Note that the .gpkg format is a compressed file. You can use a compression tool (like 7zip) to verify the archive is not damaged.

Gramps will import compressed or expanded archives.

Problem solved.Thanks for your input.

1 Like

Was the solution in one of the replies? Or did you have to do something else?

Wherever possible, we like to have a ‘Solution’ marked in the ‘Help’ forum threads.