Addon Manager on Mac issues

I manually uploaded the FamilySearch plugin from github.

The good news: The plugin works fine once I manually add the dependencies.

The bad news:

  1. I went to the new Addon Manager and the gramplet does not appear. So I cannot see the Requires button to identify what is required as a dependency. Should a manually uploaded (or even a locally developed) plugin show up here?

  2. When I look at the requirements for another gramplet, the popup reports the info on the Mac (Intel version) but instead of a check or x for status, I get a bogus icon.

No. The Addon Manager only lists entries in the listings file. It is intended to be used like an extensions library or an app store.

It is possible to create a local project with a listings file that includes an addon that you are developing.

We use the unicode characters “\u2714” for a tick and “\u2718” for a cross. What values should I use foe a Mac? I could use “Installed” and “Not installed” instead, but I quite like the tick and cross.

These may need to be translated anyway. I think that in Japan they use a circle instead of a tick/check mark.

I think the following will work. It does on my Mac. BALLOT X (2717) and HEAVY BALLOT X (2718) do not seem to work. Neither does HEAVY CHECK MARK (2714).

return “\N{CHECK MARK}” if value else “\N{CROSS MARK}”


This solution doesn’t work for me.
I’m seeing a similar issue with the death date icon in relationship view. Strangely, the icons for birth and marriage dates seem to render correctly. This is with Gramps 5.2 on both Apple and Intel versions of macOS.
On bug 0013194, jrails proposed a fix using a file ~/.config/gtk-3.0.css but this didn’t work for me.

Have you tried using the Themes addon and choosing a different Font in the Preferences?

Reminds me of this discussion

Thanks @emyoulation

In Gramps settings (aka preferences), there is a tab for genealogical symbols. If I check the “use symbols” box and select an available death symbol, it appears to fix this bug.
It looks like 5 of the symbols in the list are not available.


1 Like

We seem to be mixing two issues here, both due to the limitations of the default font on the Mac.

  1. Addon Manager Requirements cross mark and check mark
  2. Genealogical symbols for Death

I think all default symbols should be valid on the Mac (since all Mac users will be impacted, and it worked fine in 5.1.6).

I have submitted a PR for #1.

For #2: The Death symbol - the code uses unicode Latin Cross (271D) as the default and has a fallback.

  • 5.1.6 used a fallback of “+” for Death.
  • 5.2 uses a fallback of “:latin_cross:” (Latin Cross), which is not valid on the Mac.

Having a fallback that is exactly the same as the default is self-defeating. I suggest we revert the fallback to + for the Death symbol.

It appears that there is an underlying issue with how Gramps is using symbols. The Addon manager and the death symbols are just 2 symptoms of this.
Specific workarounds can be done for these 2 instances, but it would be better to fix the underlying problem. On the bugtracker, jrails mentioned using the gtk config file, which sounds like a more robust fix (if it worked). Hopefully there is something like that which will fix all the symbols used by gtk in Gramps.

A fix has been posted on bug 0013194 by jrails. This involves creating a file ~/.config/gtk-3.0/gtk.css with the contents:

* {
   font-family: systemui, Menlo;
1 Like