Unable to start the project on my server

My Server is Ubuntu 23 from Digital Ocean with 4GB RAM and 80GB SSD

I followed this document

git clone git@github.com:gramps-project/Gramps.js.git
cd Gramps.js

And after that I ran docker compose command in this fresh server

docker-compose up -d

Initially I got some errors like problem in creating users (something related to database connections) by these errors were skipped and docker compose was successful.

When I open browser and try to open my server IP address (on 80 port), it automatically redirects http to https. But the docker compose opens only 80 port and now auto redirect leads to 443 port which is not open.

When I tried https://:5555 it opens the a web page which was trying to load for 10-20 seconds and then it shows only blank page with browser title bar titled with “Gramps Web”. But the page is completely blank

I’m not sure how to fix it. Please help me.
Thanks in advance

Duplicate of this issue: Unable to start the project on my server, page is not loading · Issue #291 · gramps-project/Gramps.js · GitHub

Let’s continue the discussion there.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.