Prefix field in name is doubling anything entered

I am using Gramps 5.1.2 on Ubuntu 20.04.1

This is not a new issue, I just keep forgetting to ask. Since moving to 5.1.2 months ago, anytime I enter anything in the Surname prefix field, it doubles.
I use the following order for names
Title Given “Nickname” Prefix Surname Suffix

I have searched the manual and this site, but cannot find anything relevant.

Does anyone know why it does this and is there anyway I can correct it.

The Surname option takes in all parts of what makes up a surname - Surnames with prefix and connectors. This is in contrast to the Rawsurnames.

At the top of the Display Name Editor are all the options and what it will include. And as you add options the Example will start filling in showing what will be displayed.

So just remove the Prefix. It is already included in Surnames.

And a note. Putting the Title at the start will display properly. It will play havoc with sorting. “Dr. John…” will sort with the “D’s”. You can override this sorting in the Name Editor.

1 Like

thank you very much, I figured it was something simple. :slightly_smiling_face:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.