Incompatibility issues with Libre Office Calc and Excel?

I am running Gramps ver 5.1.3 and recently upgraded to a new computer with Windows10 (on my older computer I had Windows 8).
Already on my old computer, I had incompatibility issues with Gramps and Libre Office Calc: when I had Calc open, I couldn’t scroll in Gramps. I.e. I could for instance not scroll down in a list of people in the Person view. However, on that system everything would return to normal if I just closed Libred Calc.

Since I started to use my new Win10 computer, I have the same problem but worse. Now it is no longer enough to close Calc. I also have to reboot my computer, at times I have to reboot it twice, in order to be able to use scroll functions in Gramps. Another weird thing is that on my old system, I could run Excel (an old version) and Gramps together without problems. In my new computer I have the latest version of Excel, and it causes the same incompatibility issues as Libre Calc.

Even weirder: occasionally there are no incompatibility issues. I.e. sometimes, but rarely, I can run Libre Calc and Gramps together without that anything bad happens. Which of course makes trouble-shooting really hard.

I don’t understand this. Are there any known incompatibility issues? Could it be related to any of the add-ons for Gramps that I am using? I’m using quite a few add-ons, but I primarely work from the Relationship Combined View, which I think is an exceptionally useful and well thought out add-on.

I should add that I’m running Gramps as an Administrator, and that I’m using the Adwaita Theme.

Any thoughts on this would be much appreciated.

Thanks in advance,
Emma Marie

There is a “Fixed Scrollbar (Requires Restart)” option in the Themes Add-on. Either: 1) the problem that it was created to address, or 2) the fix itself; might be related to the scrollbars issues afflicting these applications on your OS.

Please try changing this to see if there is impact.

If the add-on is installed, toggle the setting. Then try disabling/uninstalling the add-on. (A task that is easiest when using the Plugin Manager Enhanced add-on.)

If the add-on is not installed, install it. Then try toggling the settings.

Please keep us apprised of the results.

1 Like

Thank you so much for the reply.
The box for Fixed Scrollbar was checked. I removed it, returned to default settings for Adwaita, rebooted Gramps, and so far it works! But, as described in my original post, it seems that although most of the times I have this problem, it occasionally doesn’t show up. So I think I will have to wait a little longer, maybe a couple of days, before I can say if it really helps, or if it is just temporary.

Emma Marie

1 Like

Unfortunately, the steps I made yesterday didn’t work in the long run. Today, after running Libre Calc, I had the same problems as previously - no scrolling possible, and just rebooting Gramps wasn’t enough to sort it, I have to reboot the computer.
I’ll continue with your extended suggestions and write back when I know more.
(I do NOT have the box “Fixed Scrollbar” checked anymore, I removed that yesterday)

Emma Marie

Can you mention why? By default Administrator in Win 10 is disabled!

What version of Libre Office are you using and is it also in Admin mode?

Try seeing if restoring to and running Gramps portable causes the same issue?

Can you describe if you are using a Laptop with a touchpad or touchscreen or desktop with a mouse etc…?

Personally I’m unable to recreate the issue… and no one else has reported the issue on the bug tracker

When you moved to the new computer did you create and then restore from a Gramps backup file or was the Gramps user directory only copied across?

This sounds like a case of dueling patches & versions?

There are a lot of modifiers for scrolling behavior. Including OS preferences overlays that change the interpretation of wheelmouse. i.e., which keyboard modifier key (none, shift & Ctrl. optionally Alt) performs zoom, vertical or horizontal scrolling. And even more variation for mousewheels that support center button click or tipping. So, if you have a sophisticated mouse driver with lots of options, we’re looking at another layer of GUI interactions.

Plus there’s the question of if you’re using a version of LibreOffice (7.2?) that installed Gtk4. (I need to look … but I think Gramps expects Gtk3.)

This could be simply a focus issue. You usually have to click the mouse on each program/window to gain scrolling privileges in that program.
Always check the simple things first.

No, I wish it had been that simple, but I definitely have tried in all possible ways to gain scrolling privileges. Also, as I explained in my first post, there seems to be some kind of conflict triggering this, as it doesn’t always happen when I’m using Libre Office Calc or Excel.

Well, I’m using Libre Office, so the Gtk should then be 3, shouldn’t it?

I’m using a standard mouse, and also a standard mouse on the previous Windows 8 computer, where I also had the same problem. So I don’t think it’s mouse related, either, and it is definitely related to calculation programs.

I have both Gramps 5.1.4 and Libre Office 7.2 installed, and have had it for ages… No problems on Win 10, nor on Win 11.

It can be as simple as a driver issue.

Recommend you to be sure have the latest drivers for your Graphic Card and Mouse (if you have any special type of mouse, this can be really important).
Same if you have any other special input devices…

I have had many strange problems with my AMD Graphic Cards when running with the driver that is provided through Windows Update…

Install the latest Graphic Driver from either NVidia, AMD or Intel and see if it solve your problem.

Try upgrade Libre Office to the latest version and remember to run the installer with elevated rights (administrator). e.g. Right Click and chose “Run as administrator”.

Yes, I switched to running as admin when I experienced these problems, in order to see if it would sort anything out. But it didn’t.

Ver No, I’m not running this in admin mode.

As I haven’t been using Gramps portable at all, I’ll try this as a last option.

I’m using a laptop with a standard mouse (2 buttons + wheel), not blue tooth, The touchpad is set to be disable when mouse is connected.

I used a backup-file (from safety-backup).
However, the content in User/AppData/Roaming/Gramps I did just transfer to the new computer (which meant that the add-ons worked from scratch and that I got all the filters).

As I am typing here, I’m starting to get uncertain if I possibly, by not thinking, actually did copy the folders INSIDE my Gramps archive from my old computer (those called 5c4ae799 etc etc with files like media.db, meta_data.db etc).

Emma Marie

Well, after reading here, and also checking with a friend who is running Libre Office with Gramps, I am also sure that it is only I who am having a problem.
I don’t think it’s a driver issue, though. This computer is brand new and the NVidia drivers are updated. I also had the same problem on my previous computer, which was Win8 (on Win10 now) and an older version of Libre Office.
I could try and run Libre Office as administrator, of course, this I haven’t done yet.

Emma Marie

A wheelmouse is not a standard mouse. So a driver issue is increasingly likely. It might be a Microsoft brand 2 button wheel-mouse but there are a multitude of variants of that and a frightening assortment of drivers. (Remember when standard mouse in MS meant a wired 2-button optomechanical mouse for a 9-pin serial port and installing a new driver meant blocking out a significant chunk of time for troubleshooting?)

Yeh the mouse driver and audio driver on Windows is some strange thing…

I have a 4 button, clickable wheel, ergo mouse of unknown brand, with 3 different optical resolutions, and it just works, while my Logitech 4 button, doesn’t even work properly with the Vendor specific driver…

Do you use any hardware on your new computer that you also used on the old computer?

Mouse, Card Reader, Scanner, Printer, etc.

Is the new and old computer of the same brand?
e.g. is the motherboard on both e.g. Asus, or Dell, or HP etc.?

It can actually be a USB error…

If you open your Event Viewer and scroll through all your different messages their, do you find any Yellow or Red error messages?

Most likely under “System”, but also possible under “Application”

You can flush the log by right click the different categories, and then try the same workflow, to see if it generates any errors, and when the logs are flushed/deleted, it is easier to see the errors (all is timestamped).

I don’t know if my experiences are related, but I will share them. Even when a vertical scrollbar fails to appear, I am able to scroll vertically using the wheel on my mouse. And I don’t think the horizontal scrollbar has ever been missing. (I am running Gramps 5.1.4 on Mac 10.14.6.)

Yes, of course you are right.
I have now switched to a mouse of another brand (logitech) as I realize that I have been using a mouse of the same brand (Trust) on both my old and my new computer.

I have also completely uninstalled/reinstalled the themes section, and will now wait and see if the problem reappears again (as I wrote before, it doesn’t occur more than say 75 % of the times when I’m using Gramps and Libre Calc. Therefore, I try to trouble-shoot as much step-by-step as I can, so that I can report back if I find the culprit).

1 Like

Well, I just removed and replaced a mouse that was of the same brand (not the same mouse, though) as I had been using on the old computer. Else, I do not use any hardware with this computer that I used with the older one. The computers are of different brands. Previous was an ASUS, this is a Ionico.

I don’t find any messages in the Event Viewer that are error messages (assuming that with Even Viewer you mean the bar to the right on the screen that shows up if click on the “talk-bubble” - I’m not a native english speaker. If you mean somethng else, please explain).

Emma Marie

1 Like

this is Event Viewer:

You access it by right click your start button and chose “Event Viewer”, or, you can click the Windows button and start type “Event Viewer”, you should get an icon for it then…

Expand the “Windows Logs”, and then “System”… see if you have any errors there, and in the “Applications” category…

If you tell us your native language or Windows GUI language, we can most likely find the correct name for it for you… I Only have access to English and Norwegian…

Thank you so much for this explanation, StoltHD! I will check that out for sure.

Seems we are almost neighbors then, because I am from Sweden. In general, I find it easier to use english as computer language (it took me quite some time to understand that “insticksmodul” in the Gramps translation was supposed to be something as common as a plugin, which I guess works in all languages).

Anyway, feedback on my earlier posts:

Yesterday, I switched to another mouse, and also uninstalled-reinstalled the Themes-addon.

That didn’t help. After I started Excel today, the problem returned. But, this time I was focused on trouble-shooting, so I saw exactly what triggered it in Gramps. I.e. first, Excel and Gramps worked together for some minutes.

Then I expanded a node in the Person section (se screen dump)

After this, I could no longer scroll with my mouse wheel, and also not expand or collapse any nodes.
But, this time I tried something new, I resized my Gramps window by dragging it so it became broader, and then reduced it again. Then, I could scroll again. Until I tried to expand a node. Then scrolling was gone again. (Note: I have realized that I actually can still use the scroll BAR, but not scrolling the normal way, by using the mouse wheel)
I tried this several times - resizing the Gramps windows temporary removes the problem, expanding or collapsing a node instantly causes the same problem again. After the problem has been triggered I always have to resize the Gramps window back and forth in order to expand/collapse the nodes.

I’m not sure my explanation is so great, but maybe it can help someone with more experience than me to figure out what is actually going on.

Many thanks to all of you that are trying to help me!

Emma Marie