Image display in gramps

I’m using Windows 10 – I had 5.1.3 installed. Everything was working fine.

I installed 5.1.5. Now if I add an image to a gallery, the thumbnail appears as a proxy text. If I click the thumbnail the image appears correctly.

I had left 5.1.3 installed, and now the same thing happens on it. I uninstalled both, reinstalled 5.1.3 – still happens. I’ve tried adding jpgs that have never been near gramps. Same thing.

This makes me think that it could be something in the wider environment, but I have no clue what.

Anybody got any ideas?

Forgot to mention - thumbnails for all images prior to 5.1.5 installation appear correctly

I’ve tried running the Thumbnail Generator. Nor joy

What “helper application” are you using in Windows for the affected image type? If it doesn’t generate thumbnails, Gramps cannot leverage it to generate them.

Try changing the Application that Windows uses to view that image file type, then rename the “thumb” folder in you Gramps User Directory. Restart Gramps and see what happens.

(It is possible, although unlikely, that your gen/utils/thumbnails.py file was corrupted during the recent download/install. It might be worth re-installing with a fresh copy.)

Thanks for the suggestions. All images were processed in Lightroom and or photoshop. The images in galleries loaded before the 5.1.5 install are all fine - that is the gramps preview displays correctly.

Windows can see these images just fine as thumbnails (i.e. to the folder in explorer and turn on thumbnail view.)

Any image loaded into any gallery since I installed 5.1.5 don’t display a preview - just the proxy I mentioned before. That includes the old 5.1.3 installation and the new 5.1.3 installation. 5.1.5 is not currently installed.

After this first showed up, I have completely uninstalled both 5.1.3 and 5.1.5, reinstalled 5.1.3 with a fresh copy of the windows installer. Since these live in separate paths there is no reason installation of 5.1.5 should have affected the 5.1.3 installation.

I did what you suggested, just for grins - quit gramps, renamed the thumbs folder, started gramps, ran thumbnail generator. If I look at that folder in explorer in a thumbnail view, the old photos (in a gallery before 5.1.5 was loaded) show as thumbnails of the image. The photos loaded after 5.1.5 was originally installed show, in explorer, with the same “proxy” image that shows up in gramps. It can’t be the Thumbnail generator, since it generates correct thumbnails for the “old” images. And the newly loaded images are from the same source (directory) as the old images and haven’t been touched by any editing software.

I’m pulling my hair out:-)

That puts me out of ideas. (We won’t talk about being out of hair too.)

Since don’t use the Media category, it isn’t something I’ve had to troubleshoot.

Before to determine what can be the difference before and after installing 5.1.5, is there any differences between thumbnail images?

Could you re-upload into gramps an image that already exists and is displayed there fine. The new thumbnail should not be displayed correctly while the old one should continue to be.

Try the following Windows command to compare the two thumbnail files byte by byte:

fc.exe /b oldthumb.jpg newthumb.jpg

It will not give the solution of issue you encouters but you will be able to at least know if the generated files are the same or not and thus confirm if something else happened on your system than the only installation of Gramps

What are the file extensions for these images? jpg, png, tiff…

I know Gramps does not like .webp files but these do display thumbnails in explorer.

So I’m not quite sure what you mean my e.g. oldthumb.jpg etc. The jpg file is not a thumbnail. To the best of my knowledge apps (e.g. explorer) generate thumbnails on the fly. For explorer they are kept in a database. I assumed Gramps is displaying the png file from the thumbs directory, but adding a duplicate image (which did not show the correct preview) didn’t result in a new png file, judging by the date stamps on the files there. The files clearly aren’t the same, apart from file type. The jpg is the source folder is 217K, the largest png file is 70K.

Am I just confused about what you are refering to as thumbnail images?

They’re all jpg files

Ok. I installed 5.1.5 on my WIndows 11 laptop. I moved the xml backup I had taken of 5.1.3 and a directory of photos (jpgs) that were working fine on the Desktop 5.1.5. Imported the xml backup - all good.
Dropped some jpgs into one of the galleries - no preview. Just the same dummy image.

Got to be a problem with 5.1.5.

OK. Some progress at last.
I hadn’t done any active genealogy work for some time - I was just using gramps to look up information. Apparently during that period I upgraded my gramps installation to 5.1.3, but never added any photos.

When I add photos with either 5.1.3 or 5.1.5 the metadata doesn’t get set correctly. If you look at the media tab on the left it lists title, id, type and path of all of your media objects. The type for photos is “image/jpg”, “image/tiff” etc. This is set correctly for all the photos added before 5.1.3. For anything added with 5.1.3 or 5.1.4 type is set to “unknown”. That’s why gramps doesn’t display the preview correctly - It doesn’t know what type of file it is until you tell it to go out and actually open the file.

When I upgraded gramps saved then imported the data, which included all the metadata for existing photos. For all of those photos the type was correct. For new photos, no matter how they are added, it’s “unknown”.

Just for grins I installed gramps (.1.3) on my Windows 11 laptop. I moved the xml backup over along with the photos. Imported the data then re-added one of the photos. No preview, type set to “unknown”. So this isn’t just a problem on my Windows 10 Desktop.

Is it really the case that this isn’t happening for anyone else. Could someone check the type field in the media manner tab for a photos they’ve added with 5.1.x to check the value of the type field? And whether the thumbnail preview displays correctly in the gallery?

Thanks much.