Gramps web new install without database


I’m trying to setup Gramps-web following the instructions but on startup I’m getting the following error:

ValueError: Database path for family tree 'default' not found in database directory /root/.gramps/grampsdb

This is a fresh install as I don’t have an existing Gramps database to import (first time user). Are there other steps that I need to take to initialize a new database?

More info:

  • I’m pulling
  • Using Podman instead of Docker on a headless Linux server (openSUSE MicroOS)

You’re asking about the Gramps-webAPI (via Docker?) by @DavidMStraub ?

There are an expanding number web solutions for Gramps. So it is necessary to be explicit about which version of the tool and helpful to mention the target hosting platform. (This reply was mostly to add David’s contact to the thread to tickle his attention.)

1 Like


did you get to step 5 (import database)? Or do you want to start with a new, empty database? Unfortunately, I don’t know if it’s possible to create a new, empty database with Gramps on the command line since gramps -C "new" complains about a missing input file. Does anyone know? Otherwise, you might have to create it in Gramps desktop and export the XML for the empty database.

You’re asking about the Gramps-webAPI (via Docker?) by @DavidMStraub ?

Don’t confuse users :wink: Gramps Web is the new name for the web app formed by the web API as backend and Gramps.js as frontend, both of which now live within the Gramps org.

1 Like

Merely distributing the confusion. Any and all clarification appreciated. (You response was used to clarify the wiki page. The current documentation is still targeted at those with nearly an IT professional skillset. Perhaps we’re almost to a point where a wiki could be started? Maybe with an introduction, a screen capture and a suggested skill level … and a cross-reference to the current docs & discussion threads.)

Funnily enough, I found out the following should work:

docker-compose run --entrypoint "" grampsweb \
    touch /root/.gramps/grampsdb/empty.gramps

docker-compose run --entrypoint "" grampsweb \
    gramps -C 'My family tree' \
    -i /root/.gramps/grampsdb/empty.gramps \
    --config=database.backend:sqlite \

@jeremy let me know if that works for you.

1 Like

I tried the empty file suggestion but unfortunately it did not work, Gramps didn’t seem to want to ingest it on my end.

I ended up installing the desktop version as you initially suggested to generate the xml export, sent it to the server and that worked great.

Thanks for your help everyone!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.