Recurring problems with Gramps Web

Gramps 5.2.2
Linux LMDE 6 Cinnamon

Update 1:
I could solve the issue with this command:

docker run -p "5055:5000" -e TREE=new ghcr.io/gramps-project/grampsweb:latest

Server was newly created with new login.

Update 2:
I thought all is fine now, however, starting local server gives “No connection - Reload”.
After getting to run it the syncing spoiled all, again with freezing and deleting most data on local Gramps.
Again I had to setup a new server with

docker run -p "8080:5000" -e TREE=new ghcr.io/gramps-project/grampsweb:latest

I had to upload files and media files again, to create a new tree with imported backup file.
Although I’m aware this trouble was caused by myself (see below), I now come to this conclusion:
If you don’t really need syncing via server you can avoid many many many difficulties, troubles, issues and waste of hours and hours and hours of time with only using just the export / import feature to update remote data.

The trouble started as this:
After mistakenly deleting MariaDB server data, the synchronization no longer worked, so I imported the local data in the server and overlooked the fact that not all data had been captured. This unfortunately reduced my local family tree considerably after syncing.
I finally came up with the idea of importing a backup file, first into a new family tree to prevent the data from being duplicated. I then wanted to synchronize the new family tree.
Errors occurred in the process. For example, I could no longer log in. I then created a new account, but that didn’t work either. Although the login credentials were correct, there was a login loop, i.e. I was repeatedly asked to log in again. Neither deleting the content nor the superfluous new account at server level worked. Every attempt to resynchronise from Gramps failed, or Gramps froze. After 2 hours of futile efforts, I’ll going to make myself a coffee and hope to get help here in the forum.

Now I really need help:
Today the server again has no connection:

no-connection

It can’t be a solution to change the server from “8080:5000” to “5055:5000” every day and then set it up again in the opposite direction.

Although the problem started due to a mistake on my part, there can’t be much wrong now.

This means that it probably only needs a command or a correction somewhere to ensure that the server is still accessible on the following days.

docker compose up -d
Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?

Update:
After shutdown system and boot it again the problem re-appeared. I could fix it with these commands:

docker compose up -d
Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?
sudo systemctl start docker
docker compose up -d
[+] Running 3/0
 ✔ Container 68dada19444d_grampsweb_redis  Running                         0.0s 
 ✔ Container grampsweb_celery              Running                         0.0s 
 ✔ Container html-grampsweb-1              Running                         0.0s

How can I set docker start automatically?

Update 2:
Meanwhile I searched a lot on this topic, and I can’t find what causes the issue.
In docker-compose.yml there is

restart: always

However, the daemon doesn’t restart.

1 Like

Today I noticed that the message “No connection” only appears when Grampsweb is open and I restart the system without closing it. The browser is set to start with the last session.

However, if I close Grampsweb before restarting the system, I can open it with an active connection.

After mistakenly deleting MariaDB server data, the synchronization no longer worked, so I imported the local data in the server and overlooked the fact that not all data had been captured. This unfortunately reduced my local family tree considerably after syncing.

First of all, Gramps Web does not support MariaDB, nor does the documentation mention it anywhere.

Secondly, Gramps Web clearly shows the number of objects in the database on the front page.

Third, when you try to sync an incomplete tree with a complete tree, the Web Sync Addon clearly shows that it will delete X objects, which you have to explicitly confirm by clicking a button.

If you ignored all that, you can hardly blame the software.

If you don’t really need syncing via server you can avoid many many many difficulties, troubles, issues and waste of hours and hours and hours of time with only using just the export / import feature to update remote data.

:warning: A warning to all users reading this: do not use the import feature as a replacement of the sync addon! It will lead to duplication of data.

Please use backups as advised in the documentation. In fact, Gramps Desktop creates an automated backup on closing the program, which you can easily use to restore any data lost; the “sync local to remote” option of the sync addon can be used to restore the remote (server) state.

And please apply common sense and do not click “apply” if the sync addons wants to delete a large number of objects.

Then docker is not running. This has nothing to do with Gramps.

Thanks for the clarification. It was not my intention to blame Gramps, but simply to find a solution. Even if it is ultimately a problem with Docker: Gramps is what got Docker onto my computer in the first place. Sometimes certain important information is missing.

But things have calmed down in the meantime. It was probably my mistake. However, if MariaDB is not even in play for Grampsweb, then deleting MariaDB data cannot have been the cause of the problem.

In any case, I have learned something new. I also remembered - a little late - that there are many backups. All in all, I am also very happy with Gramps!

1 Like