No connecton RELOAD

Unable to access Gramps Web. First release of 5.2. Was working fine.

Today went to update an entry on desktop then sync to web. Failed. Attempted to access web and found
Attempted reload, progress bar appeared, then same message.

No activity during reload seen via docker-compose logs -f

ip -c link show displays

. . .
3: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN mode DEFAULT group default
link/ether 02:42:e0:7a:fa:24 brd ff:ff:ff:ff:ff:ff
. . .

ip route shows:

default via dev ens33 onlink dev docker0 proto kernel scope link src linkdown dev br-3b6cbfee1fb6 proto kernel scope link src dev br-185095e8b4a2 proto kernel scope link src
192.168.xx.xx/24 dev ens33 proto kernel scope link src 192.168.xx.xx

Several reboots and “power down” (a vmware vm) did not resolve the issue.

System in untouched, by me, since last found to be working. At least a week ago.


please provide more details about your installation method. Please check the logs of the Gramps Web API container.

Installed via docker-control -d

updated via docker-control pull

Sorry but I’m more thick headed today than usual and do not recognize Gramps Web API in this list, via “docker container ls”

Might this be what is of interest?

Those are not the root cause. Can you share the full log of this container?

Hope this works.
grampweb.pdf (44.5 KB)

Thanks. I don’t see anything dramatic.

Have you tried reloading the containers? docker-compose up -d --force-recreate

Just tried as suggested, same problem.

Please check if you are out of disk space or RAM. Not sure what else to try. Please also reload the browser and check in the developer console (F12) if there is an error.

Not out of disk space or RAM.

F12 , console tab shows:

Network tab shows:

Ah. When I checked another service I found that did not respond either. It is served by an apache webserver that I also use as a reverse proxy to Gramps Web.

I restarted that server and things function normally now. I guess I was thrown off by the 503 error when attempting to access the grampsweb host via IP.


Thanks for the replies


Anyway, another useful resource for users running into similar issues in the future and searching the forum :slight_smile:

1 Like