Gramps Suddenly Not Opening

Hi, I hope this is the right place to post this.

I’ve never had any problems with Gramps, it’s always worked perfectly, however, I’ve have encountered a very sudden issue where the programme simply will not open despite it being fine just a few days ago. I have not done anything to my laptop and have tried the following to fix it:

Uninstall/Reinstall
System Restore
Booting In Safe Mode
Compatability Troubleshoot

My Gramps51.log file reads:

Summary

2021-07-20 14:55:22.846: ERROR: grampsapp.py: line 157: Unhandled exception
Traceback (most recent call last):
File “C:/msys64/mingw64/lib/python3.6/site-packages/cx_Freeze/initscripts/startup.py”, line 14, in run
)
File “C:/msys64/mingw64/lib/python3.6/site-packages/cx_Freeze/initscripts/Console.py”, line 26, in run
File “AIO/grampsaiow.py”, line 36, in
File “C:\Program Files\GrampsAIO64-5.1.3\gramps\grampsapp.py”, line 503, in main
errors = run()
File “C:\Program Files\GrampsAIO64-5.1.3\gramps\grampsapp.py”, line 485, in run
from .gui.grampsgui import startgramps
File “C:\Program Files\GrampsAIO64-5.1.3\gramps\gui\grampsgui.py”, line 230
[docs]class Gramps:
^
SyntaxError: invalid syntax

However, I have no idea what any of it means and the C:/msys64/mingw64/lib/ address line doesn’t even exist.

There is so much work that has gone into my family tree and I really can’t lose any of what I have done recently so I would really appreciate any help that anyone can give to bring the programme back.

Gramps version: 5.1.3
Operating System: Windows 10 64bit

This “GrampsAIO64-5.1.3” looks like the wrong install of 5.1.3 version.

(My ‘grampsgui.py’ file doesn’t have a [docs] in it anywhere. Line 230 is deep in a commented section containing an XML format definition.)

There was a bug in the Windoze installer and there was an immediate update to 5.1.3-2 You should be re-installing with that version.

I also suspect you were using a multiple monitor system configuration and have changed them.

Please rename the INI file at the Windoze location before starting Gramps:
%AppData%\gramps\gramps51\gamps.ini

Among other things, this will cause last dialog positions & sizes to be forgotten. Dialogs will appear centered on the main screen instead.

(The reason I suggest ‘rename’ rather than ‘Delete’ is that this INI contains an enormous number of tweaks for your Gramps: paths , formats, default person creation, etc., etc., etc. If the rename causes things to work again, you can restore to old one and just use a Text Editor to remove the entire problematic chunk with the [interface] label.)

Something seems to have corrupted the code for Gramps. I would delete the entire C:\Program Files\GrampsAIO64-5.1.3 subdirectory from your machine and then re-install Gramps. It is not necessary to uninstall Gramps first. And this will not lose your tree data. While in the area, make sure that if there are more than one version of Gramps installed, you are trying to start the right version.

I have tried both things suggested, none off which has fixed the errors.

Make sure you have a clean version of GrampsAIO-5.1.3-2_win64

The lack of information in the description you have given is forcing us to guess. It won’t be long untill both side become frustrated. So let’s start Gramps a different way so we can get more hard information.

Start Gramps from the command line interface. Any errors will be reported there.

Open a CLI window:

  • Windows-R
  • type CMD & press Enter
  • change directories to folder containing Gramps
    cd %AppdData%\GrampsAIO64-5.1.3-2 Enter
  • Start Gramps
    Gramps Enter

Tell us what errors are reported


You may want to download Gramps Portable, install it to a USB stick and verify that will run. (You can point its Family Tree tab’s “Family Tree Database Path:” Preferences to your database folder too. Then do a backup.)

Typically the path for Windows username of “WindowsUserName”, this typically would look like:

c:\users\WindowsUserName\appdata\roaming\gramps\grampsdb

The user seems to have switched over to the Reddit subreddit r/gramps to post the error messages. Unfortunately, the Android phone client app won’t let me copy that data for pasting here.

Can someone copy & post it so we can continue to diagnose?

The initial problem was a message about “the gnome-introspection being out of date”. Then Gramps started throwing errors. There is no mention whether some sort of a fix was attempted between the two.

2021-07-20 19:25:30.504: ERROR: grampsapp.py: line 157: Unhandled exception
Traceback (most recent call last):
  File "C:\Program Files\GrampsAIO64-5.1.3\gramps\gui\grampsgui.py", line 794, in do_activate
    Gramps(self.argparser, self)
  File "C:\Program Files\GrampsAIO64-5.1.3\gramps\gui\grampsgui.py", line 612, in __init__
    dbstate = DbState()
  File "C:\Program Files\GrampsAIO64-5.1.3\gramps\gen\dbstate.py", line 72, in __init__
    self.db = DummyDb()
  File "C:\Program Files\GrampsAIO64-5.1.3\gramps\gen\db\dummydb.py", line 163, in wrapped
    caller_frame = inspect.stack()[1]
  File "AIO/inspect.py", line 1494, in stack
  File "AIO/inspect.py", line 1471, in getouterframes
  File "AIO/inspect.py", line 1445, in getframeinfo
  File "AIO/inspect.py", line 828, in findsource
IndexError: list index out of range
1 Like

Is this booting Windows in Safe Mode or starting Gramps using the safe mode CLI option?

The Gnome-introspection error and the multitude of symptoms create a very non-linear description of what is happening.

I think you ought to concentrate on making certain you have secure backup copy of your research. Hopefully, you have let Gramps make backups upon exit… and can offload the last couple of those archives plus the live copy of your database.

Now that SSD storage devices have gotten a bit more mileage behind them, there are more reports of failure modes… just like with drives that have moving parts. So, regardless of your storage medium, make a backup on removable media immediately.

1 Like

Thank you all for your help! Unfortunately, I was unable to get the main app working but installing the portable version of Gramps has got my stuff back!

The problem is that since trying to sort the original issue, all my installed software has uninstalled itself. Not a big problem, I just don’t understand how that’s even possible.

What you mention is a strong indication that something is wrong with your computer, please have it checked out!

I strongly suggest backing up all your data (Gramps data and your personal data) as soon as possible to an external storage device.

1 Like