Geography "all known places for family" crash

Gramps 5.1.3, Lubuntu 20.04.2 LTS

In the last DAY I fell across a strange bug/crash. Geography “all known places for one family” fails with a stack trace. I’ve tried it for 3 different databases, and several families. It used to work.

My install is from source (I maintain a couple of small changes), and the code hasn’t changed since Feb 3 (most recent date stamp).

I suspect a linux (python) update has changed things under my feet.

Before I go “crazy” with detailed fault chasing, error reporting - is this a known “oh, that old thing” fault?


Traceback (most recent call last):
  File "/usr/local/lib/python3.8/dist-packages/gramps/gui/", line 817, in __create_page
    page_display = page.get_display()
  File "/usr/local/lib/python3.8/dist-packages/gramps/gui/views/", line 421, in get_display = self.build_interface()
  File "/usr/local/lib/python3.8/dist-packages/gramps/gui/views/", line 163, in build_interface
    self.widget = self.build_widget()
  File "/usr/local/lib/python3.8/dist-packages/gramps/plugins/lib/maps/", line 156, in build_widget
    self.change_map(None, config.get("geography.map_service"))
  File "/usr/local/lib/python3.8/dist-packages/gramps/plugins/lib/maps/", line 217, in change_map
  File "/usr/local/lib/python3.8/dist-packages/gramps/plugins/view/", line 219, in goto_handle
  File "/usr/local/lib/python3.8/dist-packages/gramps/plugins/view/", line 232, in build_tree
  File "/usr/local/lib/python3.8/dist-packages/gramps/plugins/view/", line 460, in _createmap
  File "/usr/local/lib/python3.8/dist-packages/gramps/plugins/view/", line 373, in _createmap_for_one_family
    person = dbstate.db.get_person_from_handle(
  File "/usr/local/lib/python3.8/dist-packages/gramps/gen/db/", line 1282, in get_person_from_handle
    return self._get_from_handle(PERSON_KEY, Person, handle)
  File "/usr/local/lib/python3.8/dist-packages/gramps/gen/db/", line 1263, in _get_from_handle
    raise HandleError('Handle is None')
gramps.gen.errors.HandleError: Handle is None

Perhaps it’s the same as bug report #12237

Will be solved in 5.1.4 with PR #1188

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.