Forms Gramplet fails to install

I have lost the Forms gramplet by some mysterious way.

When I try to reinstall Forms, I get the message, “No add ons were installed” and, indeed, it is not available in the list of gramplets.

I have reinstalled Gramps 5.1.2 on Mac 10.14.6 but it will still not accept the Forms gramplet.

Regards, Elvin Birth

You don’t mention what your Third party addons management section settings to check for download are?

Make sure What to check is set to New and updated addons and the Do not ask about previously notified addons setting is unchecked.

Then see how you go?

Please verify that the Forms Plug-in/add-on hasn’t been set to Hide in the Plug-in Manager

In the Preferences>General window I clicked on “Check for updated add ons now” and got the full list from which i selected “Forms” and then got the “No addon were installed” message.

In the Plug in Manager list, Forms does not show at all, neither visible nor hidden.

Since I once had and used Forms but cannot replace it, I believe my copy of Gramps is corrupted. Trashing Gramps from the Applications folder and replacing it from a fresh download does not work. How do I set up a completely clean install?

Regards, Elvin

It is highly unlikely this symptom is due to a corruption of Gramps application.

The following is PC specific but I expect Macs are similar. (Doing ResEdit cleanups of the Mac's Registry 'resource fork' was a traditional minefield for classic Mac users.) We need a macOS user of Gramps to tell us where the file is stored with the registration of Gramplets. Deleting that file (or just the subsection for the Forms Gramplet) should resolve your problem. Gramps will re-initialize any missing Gramplet registrations.

In the Windows environment, deleting an application and re-installing is just an exercise in futility for problems of this type. That is mostly helpful when the application fails massively after being corrupted or has become cluttered with debris from sequential upgrades.

All the customization is stored in the User area of rather than the Applications area of modern multi-user computers. (This is because things like the Windows security system requires the logged in user must have Admin rights to modify installed ‘All Users’ apps. But they are granted a low security area for installing single users apps & all their personal Preferences. It is relatively OK to foul up your own workspace, but not everyone else’s.) Generally speaking, uninstallers forget about flushing the customizations.

The selection of Gramplet add-on installations is definitely a customization. So, in the best case, we need to locate & delete a single item… the registration of installed add-ons/plug-ins. (Worst case, you can nuke the whole Gramps subdirectory in the user area. That’s a LAST RESORT because you could unintentionally lose some useful stuff that’s painfully convoluted to recreate. This could include archived Tree data.)

Thank you for the useful explanation. I will wait for a response from a seasoned Mac user.

Regards, Elvin

On my Mac, it is ~/Library/Application Support/gramps/gramps51/plugins/Form folder. Change gramps51 to gramps50 or gramps42 if you are running an older version. The foms (like form_us.xml) as well as the code (like is there.

I suspect you should remove the Form folder and then try to reload the add-on.

1 Like

In the Preferences>General window I clicked on “Check for updated add ons now” and got the full list from which i selected “Forms” and then got the “No addon were installed” message.

Did you actually make sure that when you ‘selected’ the Forms addon, that the little checkmark appeared in the box to the left? Just selecting the row is not enough. I’ve made this mistake myself occasionally before I started using the ‘Enhanced Plugin Manager’ addon.

There is no Forms folder in my ~/Library/Application Support/gramps/gramps51/plugins/. I have no older version to recover the folder.

I just now I tried again, making certain the box was checked. The message was “i addon was installed”, so now there are two of us who have highlighted the row with bad results.

My bad!

Thank you!

Regards, Elvin

Is the Forms Gramplet installed & available for use again then? If so, great!

From what Paul wrote, I’m guessing that means you’re still using the original Plug-in Manager and installing from the Preferences instead of switching over to the Enhanced?

I haven’t seen any reason to stay back with the original

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.