Beginner attempting merge of two family trees

I’m using GrampsAIO64-5.1.3-1 Windows 10 64-bit
very much as a beginner to Gramps.

Having created a tree for one part of the family and another tree for another part of the family, I realize this must be a mistake because of the duplication of effort with people present in both.

Therefore I want to merge them into one tree, but I haven’t been able to figure out how to get around this error:

Could not create media directory d:\documents\genealogy\gramps refd media\practice tree\Joseph Ridout c

As I’m trying to merge two trees, I intend any media files to go into the same place, but the merge seems to try to put the second tree’s media folder within the media folder of the first tree. (By the way I have no media files at all yet.)

The instructions on relative media path in preferences and subsequent use of the media manager have not yet made sense to me.

Any suggestions would be most appreciated.

If this is the case, for your two existing family trees, create a non-media xml backup.

Then when you import the two files into a new empty tree, media records are not involved.

The Relative Media Path is the base path and folder that you store all your collected media. As an example, mine is c:\user\public\Genealogy\Media All my media files are within sub-directories of the Media folder. With the Convert to a relative path checked Gramps will strip out c:\user\public\Genealogy\Media and only store the sub-directories with the file name in the Gramps’ media record path field.

This allows me to move or rename that Media folder and all I have to alter is the RMP in the Preferences General tab. I do not have to alter any of the actual media records.

Hopefully you only have a few families in common in the two trees to merge. And you are correct, it is easier to maintain one tree and use filters to view or print one branch of the tree.

As an aid, when I am merging, I created a Tag MERGE and made its color hot pink. Then if I am merging two John Smiths (or other records) that I want to ensure are the records to be merged this creates a very strong visual for the merge. Just remember to remove the tag from the resulting merged record.

Good luck and welcome.

A couple things strike me as odd in that path specification.

First, it is on a d:/ destination… which is usually an optical (CD/DVD) device. That is usually a poor destination for writing data.

Second, the path has 2 instances of ‘gpkg’ … and lots of spaces. gpkg files are compressed archives. And spaces in Windows filepaths often cause problems.

Since you say you don’t have any media yet, I think you set a bad path manually instead of browsing to a valid folder. You just never realized it because you had not tried to save to to that folder.

DaveSch, thanks so much for your advice, which solved the problem immediately. Very grateful! --Edwin

emyoulation, thanks very much for the tips. Actually D is my second hard disk. Yes I agree it’s best not to use spaces in filenames, I just got sloppy lately after several years of seemingly getting away with it, but I will try to mend my ways. --Edwin

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.