Backup with media hoover ALL media?

(Gramps 5.1.5 on Xubuntu 18.04)

Hi.

As mentioned in the Subject, a “Backup with media” seems to copy every file in the media directory instead of just the media files associated with the tree I’m backing up.

This I noticed when wanting to give her family tree to my ex-wife. I cloned the “big” tree (with all my children’s relatives), then pruned off the non-relevant people, families, etc and deleted them. (I don’t trust my filtering skills to get all of her people in one filter from my main tree.) It’s media path still points to the main media directory.

Then I backed up that new tree “with media”, only to discover that it grabbed all files.

How do I prevent this, or force it to only take the relevant files?

Welcome

We can help you build filters in the future. But for now, try this.

Instead of making a Backup with media, create an Export with media.

go to the menu >> Family Trees >> Export

Select Gramps XML Package (family tree with media)

In Export options, set the Reference Filter to Do not include records not linked to a selected person. This should limit objects that are only relevant to the people and families desired.

NOTE: Make sure to delete the media folder created by you previous attempts to prune your database.

So, File->Export the whole tree instead of doing a File->Backup?

That did in fact work. I should have thought of it in the first place…

Yes! But you would be doing this on the tree that you have already pruned out the other branches leaving just the branch you want.

Setting the export with the Reference filter set will prevent any extra notes, media, sources, citations and place from being exported.

Normally you would have done this from your main full database using a filter for just the family lines you wanted.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.