Word wrap pdf text reports?

I was wondering how to have textual notes word wrap when generating a PDF report. (Gramps: on Windows10) Have noticed that notes are in the PDF as a very long line, but can’t seem to find a checkbox that says to word-wrap or use a maximum width for notes? Have seen extremely long lines of text n the PDF generated detailed descendents report. Is there a way around this without placing carriage returns or line feeds in the notes themselves?

Thank you,

My notes are properly wrapping in reports. 5.1.4 on Win10.

Does the note wrap when viewed in the Gramps Note record?

One test you could try is to print to “OpenDocument Text” file. This may tell you what is happening with line and paragraph breaks.

Hello @DaveSch

The notes are properly wrapped when viewed in Gramps. However the “Detailed Descendents Report” shows the notes as one long line.
The output to ODT, “OpenDocument Text” shows the same.

What I noticed is that the notes in the generated output reports are only wrapped wat really long lines see bottom of screenshot.
Might there be a setting that will wrap long lines in one of the report windows that I might have missed before geneting the report?


Do you have any special styles (other than the default) set up in the “Style:” option at the bottom of the options dialog?
Are the notes set up in any unusual way when they were entered? For instance with the “Preformatted” check box set, or the “Type:” set to something other than “Person Note”?

Is the paper size set to something larger than you are actually using?

The report is already set up to wrap long lines (and adjust pagination to deal with the wrap) by default. So it appears something about your setup or notes is sufficiently unusual to mess this up.

Have set that to use Default style.

This is a note that is added on the “Marriage” event. It is displayed as “Sans” size 10, but the button “Preformatted” is off.
I do not see anything special about the formatting. I can copy and paste the text into notepad and back without any problems.
However, in notepad, the text above “Getuigen:” is also presented as one long line because there are no returns there. Attaching a pic.

I’m not seeing papersize

Later → YES. It was papersize. When I open the report, it always opened at the “ReportOptions” tab. There is actually a “PaperOptions” tab when I clicked left… thank you so much, found it and issue solved.

Thank you,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.