Too easy to unexpectedly change values in 5.2.0

While the initial reaction to this behavior was, “Cool!”, today I realized that this is causing some very unexpected behavior:

Invoke Edit > Preferences > Data tab which has many settings (combo-box UI elements) which don’t fit in the default size of the preferences window. My mouse just happened to be over one of them and I used the mouse wheel to scroll down expecting to see the settings which weren’t visible and suddenly saw a pop-up message saying, “Change is not immediate” which was unexpected and confusing. I dismissed it but it happened again and again until I realized that the mouse pointer was hovering over the “Data Format” field and as I scrolled the setting’s value was being changed inadvertently. Since settings are saved automatically, I may have changed several settings without even knowing what I changed!

So, is this setting set globally for Gramps 5.2.0 release, or is this a user-level setting that I triggered somehow?

1 Like

I agree with you. I don’t like this either.

You can disable it by selecting the option “Suppress tooltip warnings about data being saved immediately” in the “Warnings” tab.

Did not know about that setting in Preferences > Warnings. I tried it out but that setting doesn’t change the behavior (even restarted Gramps to be sure).

My concern is that settings are being changed while hovering over the combo box without the user noticing it. In fact, I realized that I was changing settings all over that page only because the Date Format setting emits a warning. I had to compare settings to my 5.1.6 installation to get them back to the way they were.

If there’s a way to disable the scroll-on-hover behavior it would be good, otherwise it’s likely we’ll see more problem reports on this and I know I’ll be making this error easily.

1 Like

The problem is the Data tab is heavy with the combo boxes. Your pointer cannot be hovering over the combo box to scroll the tab.

Is there a way to require a positive action to select the combo boxes.

The alternative is to add an additional tab so the window does not need the scroll.

Solutions that apply only to a specific dialog won’t solve the issue, because combo-boxes are found all over the place in Gramps. For example, in the Person dialog - “Type” field and “Gender” field. One has to be super careful not to use the mouse wheel - it might change the entry.

Not sure why the behavior changed with Gramps 5.2.0, but this topic has been discussed on StackOverflow:

  1. c - How to disable mouse wheel scrolling in GtkOptionMenu/GtkComboBox - Stack Overflow
  2. python - Remove ttk Combobox Mousewheel Binding - Stack Overflow

Gramps 5.1.5 also changes settings if you hover over them and use scroll wheel.

Personally, I don’t think it should be the case, no matter if the page its on is scrollable or not. It irritates me in every program where its the case and I think its poor user experience. Especially when the drop downs are almost full width and/or page is scrollable. But this is my opinion.

Is it possible to at least make a setting that turns off hover + scroll changing a field?


I didnt find anything on Mantis about this already, so I created one: (Sorry if it exists already)
0013243: [GUI behaviour] Ability to turn off hover + scroll wheel changing dropdown values. Too easy do change values without noticing.

Maybe I wrote too much on it, or too much like a an argument/sales pitch, not intended. But done is done.

1 Like