Remove unused objects will not work

I am getting an error every time I try to use this tool. Does anyone know what i am doing wrong? I am enclosing a screen shot of the error details

Reported as 11634: [no attribute ‘sort_new_with_model’] “Remove Unused Objects” in tools produces Python error and fixed in Gramps 5.1.3 when released.

ok, thank you, I will be happy when the new version comes out then

somehow I have over 100000 events that are not referenced to anyone. YAY ME! :woozy_face:

5.1.3 should be coming sooner rather than later. The developers are already working on it.

An alternative work around now (this is my preferred method) is to create a filter in each area.

Reference count = “0”

I run the relevant filter on Events, then I do Citations, then I do Notes.

When working the Remove Unused Object tool will often need to be run multiple times. A citation may not become unused until the event it is attached to is deleted first. The same for some notes.

These three areas seem to be my records that become “unattached” needing deleting.

1 Like

I thought about filter (I’ve never used them) but I’m not sure how that would help me, finding them is not an issue, I just sort the columns by name and they are all on top

the last number of the unused ones was 120395
now the last is 116482
that’s about 8 hours of deleting…

this would literal take weeks if not months…I have found out you cannot select more than 245 at a time, it simply will not do it

Another way would be to create an export (not backup).

Set the format to Gramps XML (family tree).

In Export Options, the filters will be to “Include all…” and make sure the Privacy Filter is unchecked.

But key will be to set the Reference Filter to “Do not include records not linked to a selected person” Note, any record that does not in anyway get linked back to a person or family will be excluded from the export. Any Place record that you have created but not yet attached to an event will be excluded. etc.

Once the export is created, you can then create a new empty family tree and import this export file.

2 Likes

ok, I know how to create an export like that, I will go try that

thanks. I will come back and let you know if it worked

IT WORKED!!! it got rid of all but 17 events. i think I can handle those!

:smiley: :purple_heart:

1 Like

one last question, I just noticed this and it is even in my very old backups (I looked)
when you click to edit the family and click on marriage…all the age dates are wrong

but on main entry, all the age dates are correct

is this something that is known and I just didn’t know it?

In the family edit window, the ages are calculated off of the Marriage date. In a Person edit window, all ages are calculated off of the date of Birth.

ok, thank you so very much for all of your help!!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.