Remove an attribute from the namespace

Fedora 33, Gramps version 5.1.3

I got in a hurry today and managed to create an attribute for a person that I do not want. I think I added it to only one person, and I have since corrected that person so that the attribute no longer shows.

Now the problem is that the attribute name shows up in the drop-down list of attributes. When I add attributes to a new or existing person, the bogus name gets in the way.

Two questions:

  1. How can I remove that attribute name from the list of existing attributes?

  2. I tried to create a filter that would find anyone who has a non-empty value of that attribute. It returns nothing. I used the rule "People with the personal ", then set the Personal Attribute field to the name of the attribute I want to find. The value field is blank. Is this the correct way to find a non-empty attribute with a specific name?

Thanks - Bill Gee

  1. There’s an app for that. Under Tools >> Utilities >> Type Cleanup.

It will search for all custom Types and allow you to rename or delete and will show which objects they are attached to. It is an addon so must be installed.

  1. That filter rule would have found the records if they existed. A blank value returns all instances of the type. Adding a value returns for both the Type and the specific value.
2 Likes

Have you tried the Types Cleanup tool? (3rd party add-on)

To @prculley Thanks again for this great tool!

I have and have used the Type Cleanup tool. I never considered using it for this task because I did not think Attributes were a Type. However - It works! And it shows that I had no persons using the bogus attribute.

Thanks!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.