Newbie question about database location

I keep all my documents on a NAS in my home network so I’d like to do with the Gramps database (SQLite) as well. But different to the remarks on moving database location I have seen in manual and here it is not working. I can move the database from my local computer to a location on NAS, I can open it but any change isn’t possible. System always returns a databse error and blocks the database.
Is that a problem of SQLite (I assume all the hints I’ve read maybe consider the old BSDDB database)?

By the way, I solved my problem with a work around: The SQLite database sits on the local machine while the backup goes to the NAS. So in an emergency case I’ll only loose the data of the last hour.

But I’d like to understand why it’s not working. Maybe it’s me and not the system, so if I have overseen anything I appreciate any hint.

Best regards
Gramps V5.1.6 on Linux (Tuxedo OS distribution, bases on Ubuntu 22.04 LTS)

This topic may be of interest:

1 Like

Hello Nick,

thanks for the link. I had already found it and tried the suggestions mentioned there, but at the end I stopped because version 1.00 of the SAMBA protocol isn’t supported anymore by the NAS due to security reasons.

Best regards

This looks promising:

Solution was that the write permission on the FOLDER containing the database file must ALSO be allowed for the user. He had to CMOD both the SQLite database file and the parent folder.

I have checked the permissions and think I have all necessary write permissions
On the NAS there is a folder “familie” where I store all information
In that folder I created a folder Gramps_Test to store a copy of the database currently in use

And finally that folder contains a copy of the database

I can open that copy (and it is showing all data I entered so far), but if I try to change something I’m still getting that database readonly error.
To my (limited) knowledge of file system me as the user has in all directories and for the database file itself read/write/execution rights.

The write permissions are disabled for group and others group. Write permissions are only enabled for owner.

For directories (drwxr-xr-x) and files (-rwxr-xr-x) in your screen captures.

  • The owner has full control (read, write, execute).
  • The group has read and execute permissions.
  • Others have read and execute permissions as well.

Why don’t you add “Write” permissions for the files AND the hierarchy of directories that include those files… just to see if that makes a difference.

Some users have had issues in the past; here is one that had a solution:

(Gramps-users) What has the Berkeley Database got to do with Gramps?
Keith Jacobs 29 June 2019 at 20:39 To:
Success My very grateful thanks to Nick Hall who has not only helped me whilst I struggle with Linux but also stuck with this problem which I have now managed to resolve.
The solution is to mount the network drive with
sudo mount -t cifs -o file_mode=0777,user=username,pass=password,guest,uid=1000,gid=1000,dir_mode=0777,vers=1.0 // /mnt/Samba
and then set the Gramps “Family Tree Datapath” to /mnt/Samba/Gramps
The problem, as I suspected, was the fact that files on the network drive would not report their permissions, with the above command all permissions, of files on the network drive can now be read. I now just have to master editing FSTAB with vi to make this happen at startup, though I suspect there may be some redundant options in my mount command but hay it works.
e, v
Regards Keith Jacobs

Jürgen noted that SAMBA version 1.0 was not permitted by his NAS. He would need to compose a 2.0 version string instead. (Telling us which NAS would be helpful.)

SAMBA v1 was superseded by SMBv2 and later protocols starting in 2007. Microsoft publicly deprecated the SMBv1 protocol in 2014.

the NAS comes from Synology (type RS819) and runs on DSM 7.2.
If I try to change to SAMBA V1 there is a warning that this protocol is outdated and is not recommended. You can ignore that but I don’t know what the consequences will be.

I tried to give all user write permission to the test folder within “Familie”, but that failed. After execution of
chmod 660 Gramps_Test
it still shows
drwxr-xr-x 2 jl users 0 Sep 24 20:45 Gramps_Test
Execution of that command with sudo doesn’t make a difference. Looks for me that I do not have the necessary rights to make a change.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.