Media folder on a NAS system

Running Gramps 5.1.5 on Windows 10
Just exploring ideas about where I might access my data files and tried to use a mapped Windows drive (on a local NAS) Y: → myNas\grampsMedia.

When I run the “Media verify tool”, it all sort of works and I see the access via the network, but, in the end, no results are displayed, not even an error message when I run grampsd.exe

Is this a known issue - I have not found any references, but maybe I did not use the ‘correct’ search terms

You might try looking at the Gramps log file. You can find it at:
C:\Users\your-Windows-user-name\AppData\Roaming\gramps\Gramps51.log

Start Gramps
run your test case
Close Gramps
examine the log file

some times there is nothing relevant, but there may be a clue.
You need to close Gramps to ensure all logged messages are flushed out to the file.
Also the log file is rewound/erased each time Gramps is started, so if you see something interesting, rename the file so it isn’t deleted.

(caution about grampsd.exe, it is for debugging, and some safety features are disabled, better to not use it on your real DB, make sure you have a backup or operate on a test DB)

Questions:
1 - do your media files have names that include international characters?
2 - are you using relative media paths or full paths?

As a test, put a random JPG file in your grampsmedia folder but do not add it to Gramps. Running the media verify tool should find this file as an extra file that is not in Gramps.

I have some of these files so any time I run verify, it finds them. I have never run the tool without at least these showing in the report so do not know what happens in a totally clean report.

Thank you for some more details I was unaware of regarding the logs, as well as for grampsd
After running my test, the log was empty, as it was before the run.
See also my next answer for Dave Sh

As far as I know, there are no international characters in either the path or file names.

Would Gramps or the log show anything?

I am using relative paths.

I have run the test with some extra file and this time the dialog showed both duplicates and extra.

IMO, it would be very helpful if Gramps reported something for my earlier case, even if it says: “no differences found” or something like it.

In W10, try referencing the folder using [doublebackslash]NASNAME[backslash][restofpath][backslash]FOLDERNAME rather than DRIVELETTER[COLON][backslash][restofpath][backslash]FOLDERNAME and you might find the mount is more reliable.

Thank you all for your help. Every answer helped me in some specific way, but in the end, none of them resolved my issue.
The real problem turned out to be, that for testing, I had added a couple of files to the media on my test data and then added these to the media database for my test Gramps installation.
Running the Media Verify Tool did not show these 2 files, while I had expected them to be shown at least as extra files.

In the end, I have concluded the the reason these files did not show, was because I had added them with absolute path names, while in Preferences, I had given a base path and thus should have added these with a relative path.

Lesson - watch that path

But, more to the point, I think that the MVT should perhaps have another tab for files which do not comply with the assumption of either absolute or relative paths being used.
Perhaps there is a reason for that, but for myself, and possibly other newbs like me, it wold have helped clarify the issue more directly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.