Log exceptions of concern

Gramps 5.1.6
Gramps Web API 1.5.1
Gramps Web Frontend 24.1.2
locale: en
multi-tree: false
task queue: true

Logs seen on initial ‘docker-control up -d’ concerns highlighted.

joea@Gramps-Dock:~> docker-compose logs -f
joea-grampsweb-1 | INFO [alembic.runtime.migration] Context impl SQLiteImpl.
joea-grampsweb-1 | INFO [alembic.runtime.migration] Will assume non-transactional DDL.
joea-grampsweb-1 | [2024-02-03 15:20:36 +0000] [12] [INFO] Starting gunicorn 21.2.0
joea-grampsweb-1 | [2024-02-03 15:20:36 +0000] [12] [INFO] Listening at: http://0.0.0.0:5000 (12)
joea-grampsweb-1 | [2024-02-03 15:20:36 +0000] [12] [INFO] Using worker: sync
joea-grampsweb-1 | [2024-02-03 15:20:36 +0000] [13] [INFO] Booting worker with pid: 13
joea-grampsweb-1 | [2024-02-03 15:20:36 +0000] [14] [INFO] Booting worker with pid: 14
joea-grampsweb-1 | [2024-02-03 15:20:36 +0000] [15] [INFO] Booting worker with pid: 15
joea-grampsweb-1 | [2024-02-03 15:20:36 +0000] [16] [INFO] Booting worker with pid: 16
joea-grampsweb-1 | [2024-02-03 15:20:36 +0000] [17] [INFO] Booting worker with pid: 17
joea-grampsweb-1 | [2024-02-03 15:20:36 +0000] [18] [INFO] Booting worker with pid: 18
joea-grampsweb-1 | [2024-02-03 15:20:36 +0000] [19] [INFO] Booting worker with pid: 19
joea-grampsweb-1 | [2024-02-03 15:20:36 +0000] [20] [INFO] Booting worker with pid: 20
grampsweb_celery | INFO [alembic.runtime.migration] Context impl SQLiteImpl.
grampsweb_celery | INFO [alembic.runtime.migration] Will assume non-transactional DDL.
grampsweb_celery | /usr/local/lib/python3.11/dist-packages/celery/platforms.py:829: SecurityWarning: You’re running the worker with superuser privileges: this is
grampsweb_celery | absolutely not recommended!
grampsweb_celery |
grampsweb_celery | Please specify a different user using the --uid option.

grampsweb_celery |
grampsweb_celery | User information: uid=0 euid=0 gid=0 egid=0
grampsweb_celery |
grampsweb_celery | warnings.warn(SecurityWarning(ROOT_DISCOURAGED.format(
grampsweb_celery |
grampsweb_celery | -------------- celery@dd2fd5531e1a v5.3.6 (emerald-rush)
grampsweb_celery | — ***** -----
grampsweb_celery | – ******* ---- Linux-5.14.21-150500.55.44-default-x86_64-with-glibc2.36 2024-02-03 15:20:40

grampsweb_celery | - *** — * —
grampsweb_celery | - ** ---------- [config]
grampsweb_celery | - ** ---------- .> app: default:0x7f3185184a90 (.default.Loader)
grampsweb_celery | - ** ---------- .> transport: redis://grampsweb_redis:6379/0
grampsweb_celery | - ** ---------- .> results: redis://grampsweb_redis:6379/0
grampsweb_celery | - *** — * — .> concurrency: 1 (prefork)
grampsweb_celery | – ******* ---- .> task events: OFF (enable -E to monitor tasks in this worker)
grampsweb_celery | — ***** -----
grampsweb_celery | -------------- [queues]
grampsweb_celery | .> celery exchange=celery(direct) key=celery
grampsweb_celery |
grampsweb_celery |
grampsweb_celery | [tasks]
grampsweb_celery | . gramps_webapi.api.tasks.export_db
grampsweb_celery | . gramps_webapi.api.tasks.export_media
grampsweb_celery | . gramps_webapi.api.tasks.generate_report
grampsweb_celery | . gramps_webapi.api.tasks.import_file
grampsweb_celery | . gramps_webapi.api.tasks.import_media_archive
grampsweb_celery | . gramps_webapi.api.tasks.media_ocr
grampsweb_celery | . gramps_webapi.api.tasks.search_reindex_full
grampsweb_celery | . gramps_webapi.api.tasks.search_reindex_incremental
grampsweb_celery | . gramps_webapi.api.tasks.send_email_confirm_email
grampsweb_celery | . gramps_webapi.api.tasks.send_email_new_user
grampsweb_celery | . gramps_webapi.api.tasks.send_email_reset_password
grampsweb_celery |
grampsweb_celery | [2024-02-03 15:20:40,476: WARNING/MainProcess] /usr/local/lib/python3.11/dist-packages/celery/worker/consumer/consumer.py:507: CPendingDeprecationWarning: The broker_connection_retry configuration setting will no longer determine
grampsweb_celery | whether broker connection retries are made during startup in Celery 6.0 and above.
grampsweb_celery | If you wish to retain the existing behavior for retrying connections on startup,
grampsweb_celery | you should set broker_connection_retry_on_startup to True.
grampsweb_celery | warnings.warn(
grampsweb_celery |
grampsweb_celery | [2024-02-03 15:20:40,548: INFO/MainProcess] Connected to redis://grampsweb_redis:6379/0
grampsweb_celery | [2024-02-03 15:20:40,550: WARNING/MainProcess] /usr/local/lib/python3.11/dist-packages/celery/worker/consumer/consumer.py:507: CPendingDeprecationWarning: The broker_connection_retry configuration setting will no longer determine
grampsweb_celery | whether broker connection retries are made during startup in Celery 6.0 and above.
grampsweb_celery | If you wish to retain the existing behavior for retrying connections on startup,
grampsweb_celery | you should set broker_connection_retry_on_startup to True.
grampsweb_celery | warnings.warn(
grampsweb_celery |
grampsweb_celery | [2024-02-03 15:20:40,560: INFO/MainProcess] mingle: searching for neighbors
grampsweb_celery | [2024-02-03 15:20:41,571: INFO/MainProcess] mingle: all alone
grampsweb_celery | [2024-02-03 15:20:41,585: INFO/MainProcess] celery@dd2fd5531e1a ready.
grampsweb_redis | 1:C 03 Feb 2024 15:20:24.951 # WARNING Memory overcommit must be enabled! Without it, a background save or replication may fail under low memory condition. Being disabled, it can also cause failures without low memory condition, see vm.max_map_count growing steadily when vm.overcommit_memory is 2 · Issue #1328 · jemalloc/jemalloc · GitHub. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
grampsweb_redis | 1:C 03 Feb 2024 15:20:24.951 * oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
grampsweb_redis | 1:C 03 Feb 2024 15:20:24.951 * Redis version=7.2.4, bits=64, commit=00000000, modified=0, pid=1, just started
grampsweb_redis | 1:C 03 Feb 2024 15:20:24.951 # Warning: no config file specified, using the default config. In order to specify a config file use redis-server /path/to/redis.conf
grampsweb_redis | 1:M 03 Feb 2024 15:20:24.951 * monotonic clock: POSIX clock_gettime
grampsweb_redis | 1:M 03 Feb 2024 15:20:24.952 * Running mode=standalone, port=6379.
grampsweb_redis | 1:M 03 Feb 2024 15:20:24.952 * Server initialized
grampsweb_redis | 1:M 03 Feb 2024 15:20:24.952 * Ready to accept connections tcp
mps version and Operating System)

Please use the Gramps Web category. The Gramps web API are unique help requests separate from the Gramps Project’s Help category.

Is that for future reference, or an action I must take? It appears now in “Gramps Web”, did you move it for me?

Yes. Dave moved the topic to “Gramps Web”. That was, indeed, for future reference.

The memory overcommit error is gone, with application of the fix suggested in the log, but the missing config file message continues.

I see many mentions of this in other posts, but did not notice a “fix” or it being noted as a “cosmetic” issue.