Is / an allowed character for tree name?

i am trying to get started with no existing “.gramps” directory with Gramps 5.1.3 on Xubuntu 18.04. i tried to create a tree named “Howard/Duffield” (because it will be populated from a GEDCOM i’ve download from Ancestry from a tree of the same name). the tree does not get created as seen by it not being there when i restart Gramps.

but then i tried creating one named just “Howard” and it did not get created either.

i have plenty of disk space available (over 230GB).

the “/” and the reverse slash are not allowed, but they will be automatically replaced by an “_”.

so the trees/databases should have been created.

there is likely some other problem.

when you start Gramps, are the trees/databases that you created visible to choose from?
“Family Trees -> Manage Family Trees …”

it might be that the “.gramps” directory can’t be created because of a permissions problem.

how did you install Gramps?
are you operating in English?

it was installed with the Debian-originated command “apt-get -y install”.

Yes.

it is being created. i have been junking it between tries. there is no data to keep in there. i am trying Gramps from “first time” state each time, intentionally. the first time it works from first-time, i will keep it and not junk it. i don’t want it to go into my daily backups, yet.

i see, then start Gramps

  • create one of your named trees
  • navigate to upper left of the Gramps window
  • click on the Family Trees tab/button/icon
  • what is shown to you? maybe send an image.

you say the .gramps directory is empty, do you mean that there are no files or directories at all?

i should have said it does not exist to be more accurate. i was thinking “nothing is there” and picked bad wording. i was also thinking “i emptied it” when i junked it even though my “junk” command tool move it into a ~/.junk directory (renamed so i can junk the same name many times) which is later flushed.

should i or should i not restart Gramps after i try to create the tree?

there is something i’m not following: after Gramps executes and is closed does the directory exist “~/.gramps” which you then rename to “~/.junk”?

after Gramps has run, if the “~/.gramps” directory does not exist then there is a problem with permissions or with the effective user. some installation defect.

yes, it exists, and there are files and directories in it. i restart Gramps and the names i entered are not there. names “Family Tree 1” and “Family Tree 2” do exist.

ah, Gramps doesn’t store the data in the way your are thinking.

examine the “~/.gramps/grampsdb” directory.
for each familytree/db there will be a directory.

within each directory there should several files, including:
name.txt - which contains the text display name that you gave the DB
database.txt - which identifies the type of DB, example bsddb or sqlite

the remaining files in the directory are specific to the DB type.

this internal directory structure isn’t intended to be used by human users,
and may change between Gramps versions, it may help to make it less likely
that concurrent access by other programs will corrupt the database files.

i didn’t look through the ~/.gramps directory, much. i ran a recursive listing of it, a couple times. i got the names it created by running Gramps a 2nd time before junking the directory. my junk command moves whatever into the ~/.junk directory under a time based name so i can junk N times using the same name. junking the ~/.gramps directory is just to have the next run of Gramps be like a “very first time” case. i have created my own desktop icon to run it in a dedicated workspace.

i tried to step through what i had done before from an initial state (when the ~/.gramps directory does not exist when i start Gramps). when i press Prt Sc to capture a screen image, it ends the opportunity to type in the tree name and sets it to “Family Tree 1” with an increasing number. if i click “New” again, it keeps that one with the name “Family Tree 1”. this is acting really strange. i have never seen an app react to Prt Sc before. something is trying to make this hard to do. can someone point me to the wiki manual page that tells how to do this first-time set up?

For better or worse, the only characters I know about that can ‘finish’ the user entry in the family tree manager names are ‘Enter’ ‘Up’, ‘Down’ and ‘Tab’. Others will escape out of the entry leaving it with the original value, which is ‘Family Tree xx’, where the xx is the lowest unused number with similar names. And you have to ‘finish’ the entry before you can do other operations like ‘Info’ or ‘Rename’ or ‘Load Family Tree’. Which means if you are a keyboard person, you end up hitting ‘Enter’ twice after changing or entering your own tree name to actually load the tree.

i tried from the initial state, again and pressed enter after i typed the name and it worked. i quit and started Gramps, again, and it automatically put me in family tree manager where i could see the name i had entered. so typing the name wasn’t really filling in the field it was showing in until typing Enter. i’ll have to get used to that. now, to move along and try to import a gedcom.

edit:

it turns out that doing a screenshot also ends an input. i need to find out why it can even do that. normally a keyboard shortcut is not supposed to also go to any running app. i wonder if it would if input focus is on another window. i wonder if other events would end an input in Gramps.

edit 2:

i did some tests. a automated screenshot did not do end the input, so it must be the press of PrtSc that did it. i tried it with the Gramps window defocused and it still did it that way. so something is wrong somewhere. i’ll need to try more tests.