How to retreive custom attributes and types

I don’t know how (I’ve restored a backup sometimes ago, may be it’s that - where are they stored?) but a lot of my custom event, place, … types and attributes have disappeared from dropdown lists. (why some -most- of them and not all???)

I’ve tried to use the rebuild tools but they do nothing about that. Even the Types Cleanup gramplet don’t show them.

Do I have a way to restore these lists of types and attributes?

Thanks

The process of backing up to an XML and restoring to a new tree only saves the custom ‘types’ that are actually in use in the tree. So if you had some custom types added, but not in use, they would disappear after the XML import.

FYI, the XML backup/restore was the previous way to clean up (remove) unused custom types before the ‘Type Cleanup’ tool was written.

Are there any other things in the database that are not saved in the backup?

These are used types and attributes but they have disappeared anyway (from dropdown lists, not from their objects)

It seems likely that unattached Tags will be lost as well as unattached custom types.

These will make useful item to note in the backup omissions reference.

Both have be added to wiki page while doing tests.

If you run the Types Cleanup Tool add-on, are the pull-down menus re-built?

No, I’ve tried that but nothing

But the missing Custom Types are listed in that tool, right? (A screen capture showing that dialog displaying some of the missing Custom Types might be helpful.)

3 thoughts…

  1. rebuild secondary indices (check if menus are expanded)

  2. try the more comprehensive Check and Repair Database

  3. it might be a strange interaction with the way Gramps checks the list of existing strings before adding custom types. Maybe Gramps is adding some menu items to the English array of menu items for the pop-up and being confused by you using a different (French) array of menu items?
    You might want to temporarily switch to English and see if the menus can rebuild correctly.

1 Like

@emyoulation I’ve tried your 1. and 2. ideas. Unfortunatly, they do nothing.

About point 3.; how to use English version when I’m in french (on windows)? (it should be cool to have this in preferences: change the language, restart Gramps, et voila !)

I agree about switching languages. Unfortunately (for language compatibility testing purposes), I use the default language of Gramps and only understand English. So I cannot easily test changing OS language detection and adaptation.

How about trying the PortableApps version of Gramps 5.1.4 for a Restore test in English? See if the those Custom Types are restored to menus after restoring a backup to one of its blank trees. (It is a bit of a poor choice for a test. It adds another variable instead of eliminating one.)

As a side benefit, changing languages in PortableGramps is pretty easy.

1 Like

On windows all you need to do is to create a shortcut with this, to start Gramps in English:

%comspec% /c set LANG=en_US.UTF-8 && start grampsw.exe"

Easiest is to just copy your shortcut, rename the original to Gramps - French, and rename the copy to Gramps - English (or what you like as a label).

Then you right click open properties and replace the existing Target with the one over.

Remember that you can only run one instance at the time of Gramps on Windows…

But it is possible to run Gramps in WSL2 with the help of i.e. GWSL.

2 Likes

Thanks. I’ll try this shortcut solution.

About WSL2, I’ve tried gramps with it on unbuntu some days ago. It works but I’ve got GTK errors and some gramps windows behaviors (impossible to click on some buttons,…), something is probably missing but I don’t know what now.

Install the GWSL app from Windows Store, I had to download and install the Gramps Package from git…

It also was a hassle to get all the updates for both Ubuntu, Debian and Kali installed, multiple errors because of wrong dependencies and wrong version of libraries

But I have it running on all three now…

1 Like